Author Topic: connection to storage server failed  (Read 2062 times)

Offline gobo

  • Newbie
  • *
  • Posts: 4
connection to storage server failed
« on: January 21, 2013, 08:30:09 AM »
Since about a week ago my roundcube installation stopped working. Before it worked fine and did not encounter any problems. Now all users are getting the dreaded "connection to storage server failed".

Configuration:
- FreeBSD 9.0-RELEASE
- Roundcube 0.8.4,1 (from ports)
- Postgresql 9.0.11
- Postfix 2.9.4
- Dovecot 2.1.12

I have enabled all logging, but I only see updates to the sql log where a session is created.

Quote
[21-Jan-2013 14:23:11 +0100]: query(1): SELECT vars, ip, changed FROM session WHERE sess_id = 'vrti4glbimegp5j7t1c6rq8un0';
[21-Jan-2013 14:23:11 +0100]: query(1): DELETE FROM session WHERE sess_id = 'vrti4glbimegp5j7t1c6rq8un0';
[21-Jan-2013 14:23:11 +0100]: query(1): SELECT * FROM users WHERE mail_host = '' AND username = '';
[21-Jan-2013 14:23:11 +0100]: query(1): SELECT * FROM users WHERE mail_host = '' AND alias = '';
[21-Jan-2013 14:23:11 +0100]: query(1): DELETE FROM session WHERE sess_id = 'vrti4glbimegp5j7t1c6rq8un0';
[21-Jan-2013 14:23:11 +0100]: query(1): INSERT INTO session (sess_id, vars, ip, created, changed) VALUES ('vrti4glbimegp5j7t1c6rq8un0', 'language|s:5:"en_US";temp|b:1;skin|s:5:"larry";', '145.99.178.221', '2013-01-21 14:23:11', '2013-01-21 14:23:11');

I have already tried:
- Moving the PSQL session to a socket instead of localhost (this seems to work, turning off the database gives a different error)
- Verified the local IMAP connection (although logging in roundcube does not seem to trigger an imap login at all)
- Cleared the preferences from the users table
- removed the users from the users table
- cleared out the sessions table

all to no avail.
Could someone help me debug this problem further? I'm at a loss currently where to look.

Offline JohnDoh

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 1,501
Re: connection to storage server failed
« Reply #1 on: January 21, 2013, 12:00:17 PM »
that means it can't connect to your imap server, have you tried telnetting from your webserver to your imap server that is a good way to make sure there any firewalls in the way make sure you type the hostname/ip just as it is written in your rc config.
Roundcube Plugins: Sieverules, SpamAssassin Prefs, and moreā€¦

Offline gobo

  • Newbie
  • *
  • Posts: 4
Re: connection to storage server failed
« Reply #2 on: January 21, 2013, 02:02:02 PM »
that means it can't connect to your imap server, have you tried telnetting from your webserver to your imap server that is a good way to make sure there any firewalls in the way make sure you type the hostname/ip just as it is written in your rc config.

Yes, I can "telnet localhost 143" and use regular IMAP4 commands. Which is exactly what is in my config (default):

Quote
$rcmail_config['default_host'] = 'localhost';
$rcmail_config['default_port'] = 143;

However, I've enabled logging also for IMAP, but there is no IMAP log at all and also nothing showing in my mailserver log about a (failed) login attempt

Offline gobo

  • Newbie
  • *
  • Posts: 4
Re: connection to storage server failed
« Reply #3 on: January 28, 2013, 04:33:13 AM »
Okay, I'm getting the impression that a recent PHP upgrade is the cause of this. It appears that PHP has become somewhat stricter since then:

Code: [Select]
[Mon Jan 28 10:25:07 2013] [error]  PHP Strict Standards:  Non-static method PEAR::setErrorHandling() should not be called statically in /usr/local/www/roundcube/installer/utils.php on line 70
[Mon Jan 28 10:25:07 2013] [error]  PHP Strict Standards:  Non-static method rcube_install::get_instance() should not be called statically in /usr/local/www/roundcube/installer/index.php on line 61

php.ini has `error_reporting = E_ALL & ~E_DEPRECATED`
`roundcube/program/include/iniset.php` has `    'error_reporting'         => E_ALL &~ (E_NOTICE | E_STRICT),`

I don't understand why these messages are appearing and why they're causing roundcube to fail.

Offline gobo

  • Newbie
  • *
  • Posts: 4
Re: connection to storage server failed
« Reply #4 on: February 05, 2013, 03:32:36 AM »
I've just upgraded Dovecot to 2.1.14, and now it seems to work again. No idea what was wrong as there was no feedback in the logs of Roundcube, even with the knob turned up to full debug on everything.