Author Topic: Inhalt des Spam-Ordners wird nicht angezeigt  (Read 142 times)

Offline rossmart

  • Newbie
  • *
  • Posts: 7
Inhalt des Spam-Ordners wird nicht angezeigt
« on: February 21, 2017, 10:33:40 AM »
Hallo zusammen,

vielleicht kann mir jemand von euch einen Tipp geben :o).

Folgendes Problem:
Die E-Mails unserer Benutzer (Linux-OSS-Server) werden automatisch im Ordner /var/spool/imap/<username> abgelegt. In diesem Ordner bestehen noch weitere Unterordner, wie z.B. für Spam der Unterordner /var/spool/imap/<username>/Spam.

In diesem Ordner befinden sich bei vielen Benutzern auch Spam-Nachrichten. Diese werden aber unter Roundcube nicht angezeigt.

Nun habe ich versucht, über Roundcube Konfigurationsdateien das Problem zu lösen. Dazu habe ich in der \roundcube\config\defaults.inc.php folgende Variablen zu anzupassen:

$config['junk_mbox'] = 'Spam';
$config['create_default_folders'] = true;

Schaue ich nun in Roundcube unter "Einstellungen >> Spezialordner", so kann ich dem Bereich "Spam" einen Ordner zuweisen. Leider wird hier aber der Ordner "Spam" als Ordner nicht angeboten.

Folgende Änderung habe ich nun probiert:
$config['junk_mbox'] = 'SpamTest';
$config['create_default_folders'] = true;

Melde ich mich nun neu als Benutzer an, wird wie vorgesehen automatisch der neue Ordern 'SpamTest' unter /var/spool/imap/<username>/. Außerdem wird dieser Ordner nun auch unter Roundcube angezeigt und kann dem Bereich "Spam" zugewiesen werden.

Es scheint also so, dass man unter "$config['junk_mbox'] = ..." neue Ordner erstellen und bei Roundcube registrieren kann. Man scheint mit dieser Option bestehende Ordner nicht bei Roundcube registrieren zu können.

Mache ich etwas falsch oder gibt es eine andere Möglichkeit, bestehende Ordner in Roundcube zur Auswahl bei den Spezialordnern anzeigen zu lassen? Im Idealfall gibt es so eine Art Synchronisation der bestehenden User-Ordner in mit Roundcube!?

Kann jemand helfen?

Danke,
Martin

Offline rossmart

  • Newbie
  • *
  • Posts: 7
Re: Inhalt des Spam-Ordners wird nicht angezeigt
« Reply #1 on: February 21, 2017, 04:07:43 PM »
Hmmm. Es hat sich seltsamerweise erledigt.

Mit den korrekten Einträgen in der \roundcube\config\defaults.inc.php  und mit ein wenig Herumgespiele unter Einstellungen >> Ordner ging es plötzlich.

Danke trotzdem :o)