Author Topic: 1.2.4 Return Receipt Not Functioning  (Read 429 times)

Offline runit1012

  • Newbie
  • *
  • Posts: 4
1.2.4 Return Receipt Not Functioning
« on: August 06, 2017, 10:29:38 PM »
Hi folks. I love this forum and have been a reader for a long time. I have searched all over for issues with Return Receipts, but I cant seem to find any solutions. I must be doing something wrong.

Using roundcube webmail when my users check the return receipt option nothing happens when the recipient opens the message in their roundcube. No receipt notification is sent. I see no noticeable error in the logs. Is there a setting that needs to be changed or is this the intended behavior?

Steve

Offline SKaero

  • Administrator
  • Hero Member
  • *****
  • Posts: 5,129
    • http://SKaero.com/
Re: 1.2.4 Return Receipt Not Functioning
« Reply #1 on: August 07, 2017, 01:02:14 AM »
Maybe mdn_requests setting has been set to 2.
Code: [Select]
// Behavior if a received message requests a message delivery notification (read receipt)
// 0 = ask the user, 1 = send automatically, 2 = ignore (never send or ask)
// 3 = send automatically if sender is in addressbook, otherwise ask the user
// 4 = send automatically if sender is in addressbook, otherwise ignore
$config['mdn_requests'] = 0;

Offline runit1012

  • Newbie
  • *
  • Posts: 4
Re: 1.2.4 Return Receipt Not Functioning
« Reply #2 on: August 07, 2017, 07:05:33 PM »
Just a correction... I am not set to 2, we are set to 1 (send automatically). We also tried 0 (Ask The User) and no luck on 1.2.4 version of Roundcube. What would be different between 1.2.4 and 1.3 that would cause this not to send.

Offline runit1012

  • Newbie
  • *
  • Posts: 4
Re: 1.2.4 Return Receipt Not Functioning
« Reply #3 on: August 08, 2017, 08:50:02 PM »
Anybody that has 1.2.4 installed able to verify if their read receipts are working correctly?