Author Topic: Composer: Outdated packages cannot be updated  (Read 157 times)

Offline pauLee

  • Jr. Member
  • **
  • Posts: 28
Composer: Outdated packages cannot be updated
« on: September 12, 2017, 10:07:24 AM »
When I make a "php composer.phar outdated" to list my outdated packages, I can see the following packages:

Code: [Select]
/webmail$ php composer.phar outdated
endroid/qrcode                     1.6.6   2.3.2   Endroid QR Code
phpunit/php-code-coverage          4.0.8   5.2.2   Library that provides collection, processing, and rendering functionality for PHP code coverage information.
phpunit/phpunit                    5.7.21  6.3.0   The PHP Unit Testing framework.
phpunit/phpunit-mock-objects       3.4.4   4.0.4   Mock Object library for PHPUnit
sebastian/comparator               1.2.4   2.0.2   Provides the functionality to compare PHP values for equality
sebastian/diff                     1.4.3   2.0.1   Diff implementation
sebastian/environment              2.0.0   3.1.0   Provides functionality to handle HHVM/PHP environments
sebastian/exporter                 2.0.0   3.1.0   Provides the functionality to export PHP variables for visualization
sebastian/global-state             1.1.1   2.0.0   Snapshotting of global state
sebastian/object-enumerator        2.0.1   3.0.3   Traverses array structures and object graphs to enumerate all referenced objects
sebastian/recursion-context        2.0.0   3.0.0   Provides functionality to recursively process PHP variables

But making a "php composer.phar update" tells me ...

Code: [Select]
/webmail$ php composer.phar update
Loading composer repositories with package information                                                           Updating dependencies (including require-dev)
Nothing to install or update
Generating autoload files


Which information is wrong or how can I update the packages?

Offline alec

  • Hero Member
  • *****
  • Posts: 1,033
Re: Composer: Outdated packages cannot be updated
« Reply #1 on: September 12, 2017, 10:37:44 AM »
You can't just update packages without updating the code that uses them. Most of them are for development only, use --no-dev flag.

Offline pauLee

  • Jr. Member
  • **
  • Posts: 28
Re: Composer: Outdated packages cannot be updated
« Reply #2 on: September 12, 2017, 10:43:46 AM »
You can't just update packages without updating the code that uses them.
Sorry, I don't understand completely - which code do you mean?

Quote
Most of them are for development only, use --no-dev flag.
I will do so. Thank you!

Offline alec

  • Hero Member
  • *****
  • Posts: 1,033
Re: Composer: Outdated packages cannot be updated
« Reply #3 on: September 12, 2017, 12:09:50 PM »
Newer versions of some libs can be incompatible with current Roundcube code.