Author Topic: r4307 - Exchange Default foldr config issue  (Read 3587 times)

Offline rayruest

  • Newbie
  • *
  • Posts: 3
r4307 - Exchange Default foldr config issue
« on: December 03, 2010, 08:55:06 AM »
I am running Exchange 2003, and trunk-r4307.   The Exchange folders for drafts, trash, sent and junk display fine.  RC also displays message folders in duplicate.  I have cleared all db tables and restarted the server... same result.  

My config for the folders is :

$rcmail_config['drafts_mbox'] = 'Drafts';
$rcmail_config['junk_mbox'] = 'Junk E-mail';
$rcmail_config['sent_mbox'] = 'Sent Items';
$rcmail_config['trash_mbox'] = 'Deleted Items';

I have tried :

$rcmail_config['default_imap_folders'] = array('Inbox', 'Drafts', 'Sent Items', 'Junk E-mail', 'Deleted Items');

and

$rcmail_config['default_imap_folders'] = array();


See attached image for result.  Clicking on any of the duplicate folders produces a "The requested item could not be found" error.  I would like only the Exchange folders to appear.  Anything I can do to change the config, or is this a small bug?

Offline alec

  • Hero Member
  • *****
  • Posts: 1,009
r4307 - Exchange Default foldr config issue
« Reply #1 on: December 03, 2010, 08:59:51 AM »
Enable imap_debug and show the server response for LIST/LSUB commands.

Offline rayruest

  • Newbie
  • *
  • Posts: 3
r4307 - Exchange Default foldr config issue
« Reply #2 on: December 03, 2010, 09:09:30 AM »
I dont see LIST in the log, but here is the LSUB section:

C: A0004 LSUB "" "*"
S: * LSUB () "/" Trash
S: * LSUB () "/" Sent
S: * LSUB () "/" Junk
S: * LSUB () "/" Drafts
S: * LSUB () "/" "Sent Items"
S: * LSUB () "/" "Junk E-mail"
S: * LSUB () "/" "Deleted Items"
S: A0004 OK LSUB completed.

Is this telling us that IMAP is passing the extra "Trash", "Sent", and "Junk" folders... even though Exchange isn't using them?  (They do not exist in the mailbox)

Offline alec

  • Hero Member
  • *****
  • Posts: 1,009
r4307 - Exchange Default foldr config issue
« Reply #3 on: December 03, 2010, 09:13:38 AM »
Exactly. LSUB is for subscribed folders, so they don't need to be existing. I don't know where Exchange stores subscribtion data, if you didn't find it, you can try to create these folders and delete them (in Roundcube). Or maybe it will be possible to just unsubscribe them via new folder manager in Roundcube (Settings->Folders).

Offline rayruest

  • Newbie
  • *
  • Posts: 3
r4307 - Exchange Default foldr config issue
« Reply #4 on: December 03, 2010, 10:46:19 AM »
Thanks!  I tried a few other users and everything is fine with them.. seems to be only a few of us early adopters.  I have a theory:

The original folders names were created when I initially set up RoundCube and told it to create the folders at logon.  The default folder names were created in the Exchange mailbox.  I have since deleted them from the mailbox.  I found them lingering in the deleted items recovery (we have have a short retention period set).  I deleted them permanently but they still reappear.  I think Exchange IMAP will not stop dishing these out until they purge.  I hope this will occur tonight with our backup.  Just a theory...  I will post the results either way in case any Exchange users stumble across this in the future.  Either way it looks like only us early adopters are effected.. not a show stopper either way.

Thanks again for the assistance/IMAP lesson!