Author Topic: 0.8.4 Not Using Config File  (Read 3097 times)

Offline ozzie1989

  • Newbie
  • *
  • Posts: 1
0.8.4 Not Using Config File
« on: November 18, 2012, 03:59:27 AM »
Hello all. Lots of great advice on these forums.

Running Roundcube 0.8.4 on my shared hosting. It has been working well for ages on various versions of Roundcube.

Recently however, I noticed that it wasn't loading my custom logo and page title. I've tried different versions but get the same issue.

I went back into the main config file and tried to turn the installer on, but even this doesn't work. I then deleted the main config file, and the database file but Roundcube still works perfectly!

I can't figure it out, I'm thinking that the information is being cached somewhere but wasn't aware that Roundcube could cache such information? The installation has been working perfectly for days now without either of the config files present.

Any thoughts?

Thanks  :)

Offline SKaero

  • Administrator
  • Hero Member
  • *****
  • Posts: 5,557
    • http://SKaero.com/
Re: 0.8.4 Not Using Config File
« Reply #1 on: November 19, 2012, 05:48:27 PM »
RoundCube needs its configuration files, I think you missing an install somewhere.

Offline stephanstricker

  • Newbie
  • *
  • Posts: 1
Re: 0.8.4 Not Using Config File
« Reply #2 on: November 23, 2012, 08:10:49 PM »
I have the exact same issue with the calendar plugin its saves the settings but not in config.inc.php.

Offline jamil_isayyed

  • Jr. Member
  • **
  • Posts: 37
Re: 0.8.4 Not Using Config File
« Reply #3 on: November 24, 2012, 07:50:51 PM »
ya i have faced this problem, i found that the problem in the owner ship and group of the gonfigartion file, roundcube uses www-data for groups and ownership, then you need to make a manipulation to the file  main.inc.php belongs to the same group (that is enough!) that your Apache server

you can do this through this comand

chown root: www-data / var / lib / roundcube / config / main.inc.php

enjoy

Thanks :D