Author Topic: Can't get my message in RC ?  (Read 3310 times)

Offline ChPortos

  • Newbie
  • *
  • Posts: 8
Can't get my message in RC ?
« on: January 10, 2007, 07:14:49 AM »
Hi everybody !

I've got an issue when I try to use any webmail client (I tried SquirrelMail and RoundCube so far) : I can't get my message in my Inbox !
Actually, what I can do :
 - send messages through SMTP (and they are well received)
 - read my message directly on the server (with the command "mail" I can read them)
 - login RoundCube and use the database

So, why RoundCube (or SquirrelMail) can't recover my messages if they are well received on the server ?

I installed courrier-imap and configured it.

Please help !


Offline NaiosKae

  • Jr. Member
  • **
  • Posts: 40
Re: Can't get my message in RC ?
« Reply #1 on: January 10, 2007, 08:44:11 AM »

Wich smtp server are you using (it is your smtp server that manage mail delivery) ?

by default postfix and exim deliver mail in /var/spool/mail/user at mbox format

If you are in this case, try to change smtp server either to deliver in $home/Maildir at maildir format or to use procmail

in case using procmail editing the $home/.procmailrc file like following will make new mails available to your webmail (and of course you can add rules to filter and order your mails directly at delivery), don't forget to run "maildirmake $home/Maildir"

# .procmailrc
# routes incoming mail to appropriate mailboxes
MAILDIR=$HOME/Maildir  # all mailboxes are in .mailspool/

if you want to get you current mails available on imap server use mb2md tool (which will convert your mbox to an imap spool) "mb2md -s /var/mail/user"

Offline rsmith

  • Newbie
  • *
  • Posts: 6
Re: Can't get my message in RC ?
« Reply #2 on: January 13, 2007, 11:12:17 AM »
The fix is listed here for postfix users:

Once i changed this, everything worked great for me, happy to have left openwebmail and squirrelmail for a better system! ;D