Author Topic: 0.9.0 - prerequesits check wrong  (Read 11225 times)

Offline pluto007

  • Newbie
  • *
  • Posts: 3
0.9.0 - prerequesits check wrong
« on: April 26, 2013, 06:26:31 PM »
Hello,

I try to install new version 0.9.0 and get the following error:

Code: [Select]
Checking available databases

Check which of the supported extensions are installed. At least one of them is required.

MySQL:  NOT OK(PHP >= 5.3 required)
PostgreSQL:  OK
SQLite:  OK
SQLite (v2):  NOT AVAILABLE(See http://www.php.net/manual/en/book.pdo-sqlite.php)
SQL Server (SQLSRV):  NOT AVAILABLE(See http://www.php.net/manual/en/book.pdo-sqlsrv.php)
SQL Server (DBLIB):  OK

I thought only ONE of them is required - as it is described?

PHP seems to be ok:
Code: [Select]
Checking PHP version

Version:  OK(PHP 5.2.17-0.dotdeb.0 detected)

Any idea?

Thanks a lot

Offline SKaero

  • Administrator
  • Hero Member
  • *****
  • Posts: 5,507
    • http://SKaero.com/
Re: 0.9.0 - prerequesits check wrong
« Reply #1 on: April 26, 2013, 08:53:46 PM »
From the 0.9 release announcement: http://www.roundcubeforum.net/index.php/topic,11102.0.html
Quote
Another major change since the 0.8 series is the new database abstraction layer. In order to add support for SQLite3, the PEAR:MDB2 dependency was dropped and Roundcube now uses the native PHP Data Objects (PDO). It's enabled by default since PHP 5.1 and is considered stable and well-developed. One drawback, however, is a small lack in the MySQL PDO driver which makes PHP 5.3 a requirement for this version of Roundcube when using the MySQL database.

Offline pluto007

  • Newbie
  • *
  • Posts: 3
Re: 0.9.0 - prerequesits check wrong
« Reply #2 on: April 27, 2013, 10:44:45 AM »
Hello,

ok, I see, maybe the inro text could be a little bit more user freindly ;-)

I enabled PHP 5.3 now in my webspace and disabled suhosin.session.encrypt in php but get the following error:
Code: [Select]
ERROR: Wrong 'suhosin.session.encrypt' option value and it wasn't possible to set it to required value (0). Check your PHP configuration (including php_admin_flag).
Any ideas why this could happen even if the  suhosin.session.encrypt is correctly disabled?

Thanks a lot
pluto

Offline JohnDoh

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 2,248
Re: 0.9.0 - prerequesits check wrong
« Reply #3 on: April 27, 2013, 12:19:07 PM »
This is just a guess but are you sure you changed the correct php.ini file and have you restarted the webserver since (to load the new config)?
Roundcube Plugins: Contextmenu, SpamAssassin Prefs, and moreā€¦

Offline pluto007

  • Newbie
  • *
  • Posts: 3
Re: 0.9.0 - prerequesits check wrong
« Reply #4 on: April 27, 2013, 03:29:39 PM »
Hello,

I changed the httpd-configuration in my confixx environment and this restarts my apache, but after your posting I uploaded a php info file and voila you are right - as I can see in the php-info file the 'suhosin.session.encrypt' option is still set to ON...?
So I informed my provider to fixx this issue.

Thanks a lot for your help.
pluto