Author Topic: 1f4) error  (Read 2683 times)

Offline ajanjigian

  • Newbie
  • *
  • Posts: 2
1f4) error
« on: January 26, 2007, 08:37:00 AM »

Well I've tried the installation instructions, checked my db.inc.php settings, searched this forum for help, and tried all of the variations suggested, to no avail. I'm still getting the 1f4) error.

This is my current db setting:

$rcmail_config['db_dsnw'] = 'mysql:/USER:PASS@127.0.0.1/DATABASE';

Where USER&PASS are the username and pw I assigned to the db I named DATABASE.

I have tried localhost and DOMAIN.ORG instead of 127.0.0.1.

I have deleted the db, recreated it, rerun the initial script.

The db has 6 files in it:

 cache
 contacts
 identities
 messages
 session
 users

My db.inc.php has permissions set to 644.

In my Cpanel SQL control panel, the db I created shows this list of connection strings:

Connection Strings
Perl    $dbh = DBI->connect("DBI:mysql:MASTER_roundcubemail:localhost","MASTER_cube","");

PHP    $dbh=mysql_connect ("localhost", "MASTER_cube", "") or die ('I cannot connect to the database because: ' . mysql_error());
mysql_select_db ("MASTER_roundcubemail");

Where MASTER is my server username. (With any db I create, mysql adds that string to the beginning of any username I select.)

Do those scripts suggest another way to setup $rcmail_config['db_dsnw']?

Thanks for you help,
Andrew

Offline ajanjigian

  • Newbie
  • *
  • Posts: 2
Re: 1f4) error
« Reply #1 on: January 26, 2007, 08:45:18 AM »
Okay, I figured it out. Because of the way my mysql is setup, I needed to add those strings to both my username and my db name to db.inc.php.

I got to the login screen, but couldn't login. Back to the drawing board we go.

A

Offline oxygens

  • Jr. Member
  • **
  • Posts: 36
Re: 1f4) error
« Reply #2 on: January 26, 2007, 02:12:43 PM »
whats your server setup?