Author Topic: update.sh 0.8.0 > 0.9.1 sqlite errors  (Read 2093 times)

Offline ferenc

  • Newbie
  • *
  • Posts: 1
update.sh 0.8.0 > 0.9.1 sqlite errors
« on: May 26, 2013, 06:25:21 AM »
Howdy,

I'm thinking of changing (hopefully for the better) the updatedb.sh script, so it can manage the sqlite2 to sqlite3 change.

I upgraded from 0.8.0 to 0.9.1 today. I used the update.sh script but this ran into problems with the upgrade from sqlite2 to sqlite3. The forever confusing (to me) sqlite error message about possible encryption signalled this. It is also mentioned in the UPGRADING file but apart from how to convert to a sqlite3 database, it has no suggestions.

I tried the upgradedb.sh script after converting, but found figuring out the --dir and --packaging parameters too much trouble. I manually fed the relevant files in SQL/sqlite to the database.

I think the updatedb.sh script or at least the text file UPGRADING could be better. What do you think?

cheers,
Ferenc