Author Topic: Error Invalid request! No data was saved. but no usable log info, please help  (Read 15358 times)

Offline Thomanji

  • Newbie
  • *
  • Posts: 3
Hi,

I moved to a new server and installed the latest RoundCube 0.9.2.
If I try to login I get the message:

Invalid request! No data was saved.

In the logs I see the following:

[18-Jun-2013 22:09:04 US/Eastern] PHP Warning:  session_write_close(): Failed to write session data (user). Please verify that the current setting of session.save_path is correct (/var/lib/php/session) in /usr/share/roundcubemail/program/include/rcmail.php on line 777
[18-Jun-2013 22:09:04 US/Eastern] PHP Stack trace:
[18-Jun-2013 22:09:04 US/Eastern] PHP   1. {main}() /usr/share/roundcubemail/index.php:0
[18-Jun-2013 22:09:04 US/Eastern] PHP   2. rcmail_output_html->send() /usr/share/roundcubemail/index.php:217
[18-Jun-2013 22:09:04 US/Eastern] PHP   3. rcmail->shutdown() /usr/share/roundcubemail/program/include/rcmail.php:0
[18-Jun-2013 22:09:04 US/Eastern] PHP   4. session_write_close() /usr/share/roundcubemail/program/include/rcmail.php:777

I am not really clear that this means and if I need to modify something without advice.
I run a CentOS 6 - 64bit, Apache latest, PHP Version 5.4.16, RoundCube 0.9.2

I did check that all PHP options are there:
   - PCRE, DOM, JSON, XML, Session, Sockets (required)
   - PHP Data Objects (PDO) with driver for either MySQL, PostgreSQL or SQLite (required)

all pear modules are installed too.

I am out of things to try and hope maybe someone can give me a tip for this.

I appreciate any help.

Thank you

Offline Thomanji

  • Newbie
  • *
  • Posts: 3
Hi,

I wanted to do an update on all the things I have tried for hours.
I tried to change the session path to /tmp but no success
changed time zone in PHP but no success.
I activated the other logs and not get a session and use log.

In the session log I get:
[19-Jun-2013 00:44:54 -0400]: Aborted session 15sbn9ai6qfhchcqf1ri7ga2l4; no valid session data found

user log:
[19-Jun-2013 00:29:42 -0400]: Successful login for accentx-thomas (ID: 1) from 175.136.161.49 in session sgofb90it8dbhkg4uidjggd124

well, no successful login until now even though it mi9ght say this.

I did run the install script again and get no errors.
I erased the MYSQL table and populated it again with the initial sql tables.

I ensured all plug-ins are disabled in roundcube.

I changed the session.save_path = "/var/lib/php/session" in php.ini to session.save_path = "/tmp" no success so I changed it back.

my tmp folder or disc is not full
df -h /tmp
Filesystem            Size  Used Avail Use% Mounted on
/dev/md127p3     102G   11G   86G  12% /

also it is chmod 1777

I am happy to answer any other questions. I hope I can figure this out since it is the only renaming issue I have on my new server.

Best wishes,
Thom


Offline alec

  • Hero Member
  • *****
  • Posts: 1,321
Disable suhosin. There's a known bug which breaks session.

Offline Thomanji

  • Newbie
  • *
  • Posts: 3
Thank you Alex for the response, it is very much appreciated.
I did already have it disabled but after I removed the .ini file from /etc/php.d to not load it at all. It started working.

ALEC you are the man !!! After spending the last 5 hours researching and experimenting you resolved it with one sentence.
Thank you so very much.