Author Topic: I can't get the Archive plugin to work  (Read 2881 times)

Offline espirates

  • Jr. Member
  • **
  • Posts: 17
I can't get the Archive plugin to work
« on: July 02, 2013, 08:10:28 PM »
I have the latest RC and even though I have listed in the plugin section of the config file, the archive button and settings don't show up.  How to get it working ?

Offline SKaero

  • Administrator
  • Hero Member
  • *****
  • Posts: 5,644
    • http://SKaero.com/
Re: I can't get the Archive plugin to work
« Reply #1 on: July 02, 2013, 10:58:57 PM »
Whats in the RoundCube error log?

Offline espirates

  • Jr. Member
  • **
  • Posts: 17
Re: I can't get the Archive plugin to work
« Reply #2 on: July 05, 2013, 12:03:43 PM »
Just this

PHP Warning:  PHP Startup: Unable to load dynamic library '/usr/local/lib/php/extensions/no-debug-non-zts-20090626/imagick.so' - /usr/local/lib/php/extensions/no-debug-non-zts-20090626/imagick.so: cannot open shared object file: No such file or directory in Unknown on line 0

Offline SKaero

  • Administrator
  • Hero Member
  • *****
  • Posts: 5,644
    • http://SKaero.com/
Re: I can't get the Archive plugin to work
« Reply #3 on: July 05, 2013, 01:35:35 PM »
That shouldn't be related, can you post your main.inc.php?

Offline espirates

  • Jr. Member
  • **
  • Posts: 17
Re: I can't get the Archive plugin to work
« Reply #4 on: July 05, 2013, 02:32:00 PM »
I found out what is causing but not sure why

The only plugins I can get to work are the one listed last.

ie

$rcmail_config['plugins'] = array('archive');
$rcmail_config['plugins'] = array('filters');

in this case only the filters will work.

if I do it like this, only the archive will work.

$rcmail_config['plugins'] = array('filters');
$rcmail_config['plugins'] = array('archive');


Is there a particular way of listing out plugins?


update:  got it working by listing out each plugin in the ()  ('filters', 'archive', etc)
« Last Edit: July 05, 2013, 02:36:51 PM by espirates »