Author Topic: apache/suPHP/roundcube : suPHP_ConfigPath not allowed here  (Read 3599 times)

Offline aschaeffer

  • Newbie
  • *
  • Posts: 1
apache/suPHP/roundcube : suPHP_ConfigPath not allowed here
« on: September 16, 2013, 05:30:54 AM »

I tried to install roundcube. I use suPHP module so there's an error because of the .htacces who tried to change some PHP value (suhosin.session.encrypt need to be off for roundcube).

I found a workarround with this function "suPHP_ConfigPath" in the .htaccess file. That should enable a php.ini file in which, it should be possible to change PHP value. But, this lead to an error.

First of all, here's my linux version :

Code: [Select]
$ uname -a
Linux aschaeffer 2.6.32-042stab072.3 #1 SMP Tue Dec 25 19:38:06 MSK 2012 x86_64 GNU/Linux

suPHP mod is enabled
Code: [Select]
# a2enmod suphp
Module suphp already enabled

Here's the error when I tried to access roundcube
Code: [Select]
$ cat /var/log/apache2/error.log
[alert] [client] /home/roundcube/www/.htaccess: suPHP_ConfigPath not allowed here

Here's my .htaccess file
Code: [Select]
<IfModule mod_suphp.c>
suPHP_ConfigPath /home/roundcube/www
<Files php.ini>
order allow,deny
deny from all

If I uncomment this, I don't get any error, so the rest of the .htaccess shouldn't be a problem.

Code: [Select]

Code: [Select]
$ ls -al
-rw-r--r--  1 roundcube roundcube  1534 Sep 13 17:05 .htaccess
-rw-r--r--  1 roundcube roundcube    30 Sep 13 17:01 php.ini

Finally :

Code: [Select]
$ cat /etc/apache2/sites-available/roundcube
<VirtualHost *:80>
        DocumentRoot    /home/roundcube/www
        SuexecUserGroup roundcube roundcube

        <Directory />
                Options FollowSymLinks
                AllowOverride all

        <Directory /home/roundcube/www>
                Options FollowSymLinks MultiViews
                AllowOverride All
                Order allow,deny
                allow from all


        ErrorLog ${APACHE_LOG_DIR}/error.log
        LogLevel warn
        CustomLog ${APACHE_LOG_DIR}/access.log combined

Si I have no idea how to solve this error "suPHP_ConfigPath not allowed here". If anybody have a hint, i would glad to hear it! :)

Thank you in advance. :)