Author Topic: Nothing Happens  (Read 7645 times)

Offline markporter

  • Newbie
  • *
  • Posts: 7
Nothing Happens
« on: July 15, 2006, 06:50:57 AM »
OK, so I set up the 0.1b release on my server as per the instructions. I set up the database by running the initial script for that and it created the tables and as far as I know I configured the db config file correctly. However, when I try loading the whole thing up instead of a login page I get a blank screen. The error logs are shown below. Any ideas?

Code: [Select]
[13-Jul-2006 00:32:33 +0100] DB Error: DB Error: no such table Query: SELECT vars, ip, UNIX_TIMESTAMP(changed) AS changed FROM session WHERE sess_id='1c5311baab486867393345c7d30843dc' [nativecode=1146 ** Table 'markporter_co_uk.session' doesn't exist] in /home/httpd/vhosts/markporter.co.uk/httpdocs/mail/program/include/rcube_db.inc on line 455
[13-Jul-2006 00:32:33] PHP Fatal error: Call to a member function on a non-object in /home/httpd/vhosts/markporter.co.uk/httpdocs/mail/program/include/rcube_db.inc on line 343
[13-Jul-2006 00:36:27 +0100] DB Error: DB Error: no such table Query: SELECT vars, ip, UNIX_TIMESTAMP(changed) AS changed FROM session WHERE sess_id='5ea8ce77e647c625daf1fd069f5dafeb' [nativecode=1146 ** Table 'markporter_co_uk.session' doesn't exist] in /home/httpd/vhosts/markporter.co.uk/httpdocs/mail/program/include/rcube_db.inc on line 455
[13-Jul-2006 00:36:27] PHP Fatal error: Call to a member function on a non-object in /home/httpd/vhosts/markporter.co.uk/httpdocs/mail/program/include/rcube_db.inc on line 343
[13-Jul-2006 00:36:31 +0100] DB Error: DB Error: no such table Query: SELECT vars, ip, UNIX_TIMESTAMP(changed) AS changed FROM session WHERE sess_id='11d5a41f6ad42793f28b645022f63f8b' [nativecode=1146 ** Table 'markporter_co_uk.session' doesn't exist] in /home/httpd/vhosts/markporter.co.uk/httpdocs/mail/program/include/rcube_db.inc on line 455
[13-Jul-2006 00:36:31] PHP Fatal error: Call to a member function on a non-object in /home/httpd/vhosts/markporter.co.uk/httpdocs/mail/program/include/rcube_db.inc on line 343
[13-Jul-2006 00:39:12 +0100] DB Error: DB Error: no such table Query: SELECT vars, ip, UNIX_TIMESTAMP(changed) AS changed FROM session WHERE sess_id='1f5321d5bd5ea2a0f2a83dd9b926b7d7' [nativecode=1146 ** Table 'markporter_co_uk.session' doesn't exist] in /home/httpd/vhosts/markporter.co.uk/httpdocs/mail/program/include/rcube_db.inc on line 455
[13-Jul-2006 00:39:12] PHP Fatal error: Call to a member function on a non-object in /home/httpd/vhosts/markporter.co.uk/httpdocs/mail/program/include/rcube_db.inc on line 343
[13-Jul-2006 00:39:16 +0100] DB Error: DB Error: no such table Query: SELECT vars, ip, UNIX_TIMESTAMP(changed) AS changed FROM session WHERE sess_id='eaaf05f214ca39a71035b293f8b808a7' [nativecode=1146 ** Table 'markporter_co_uk.session' doesn't exist] in /home/httpd/vhosts/markporter.co.uk/httpdocs/mail/program/include/rcube_db.inc on line 455
[13-Jul-2006 00:39:16] PHP Fatal error: Call to a member function on a non-object in /home/httpd/vhosts/markporter.co.uk/httpdocs/mail/program/include/rcube_db.inc on line 343
[13-Jul-2006 00:47:57 +0100] DB Error: DB Error: no such table Query: SELECT vars, ip, UNIX_TIMESTAMP(changed) AS changed FROM session WHERE sess_id='9a370863d48ade6fb1de595400d7ac04' [nativecode=1146 ** Table 'markporter_co_uk.session' doesn't exist] in /home/httpd/vhosts/markporter.co.uk/httpdocs/mail/program/include/rcube_db.inc on line 455
[13-Jul-2006 00:47:57] PHP Fatal error: Call to a member function on a non-object in /home/httpd/vhosts/markporter.co.uk/httpdocs/mail/program/include/rcube_db.inc on line 343
[13-Jul-2006 08:39:44 +0100] DB Error: DB Error: no such table Query: SELECT vars, ip, UNIX_TIMESTAMP(changed) AS changed FROM session WHERE sess_id='f417f4e4ba3d444007f5c655acc99bdd' [nativecode=1146 ** Table 'markporter_co_uk.session' doesn't exist] in /home/httpd/vhosts/markporter.co.uk/httpdocs/mail/program/include/rcube_db.inc on line 455
[13-Jul-2006 08:39:44] PHP Fatal error: Call to a member function on a non-object in /home/httpd/vhosts/markporter.co.uk/httpdocs/mail/program/include/rcube_db.inc on line 343
[13-Jul-2006 08:41:45 +0100] DB Error: DB Error: connect failed in /home/httpd/vhosts/markporter.co.uk/httpdocs/mail/program/include/rcube_db.inc on line 97
[13-Jul-2006 08:41:46] PHP Fatal error: Call to undefined function: query() in /home/httpd/vhosts/markporter.co.uk/httpdocs/mail/program/include/rcube_db.inc on line 213
[13-Jul-2006 08:41:54 +0100] DB Error: DB Error: connect failed in /home/httpd/vhosts/markporter.co.uk/httpdocs/mail/program/include/rcube_db.inc on line 97
[13-Jul-2006 08:41:54] PHP Fatal error: Call to undefined function: query() in /home/httpd/vhosts/markporter.co.uk/httpdocs/mail/program/include/rcube_db.inc on line 213
[13-Jul-2006 08:45:21 +0100] DB Error: DB Error: no such table Query: SELECT vars, ip, UNIX_TIMESTAMP(changed) AS changed FROM session WHERE sess_id='d0b76137a1f66f64af20a1f815d98582' [nativecode=1146 ** Table 'markporter_co_uk.session' doesn't exist] in /home/httpd/vhosts/markporter.co.uk/httpdocs/mail/program/include/rcube_db.inc on line 455
[13-Jul-2006 08:45:21] PHP Fatal error: Call to a member function on a non-object in /home/httpd/vhosts/markporter.co.uk/httpdocs/mail/program/include/rcube_db.inc on line 343
[13-Jul-2006 08:48:05 +0100] DB Error: DB Error: no such table Query: SELECT vars, ip, UNIX_TIMESTAMP(changed) AS changed FROM session WHERE sess_id='8e3ff1b57dfc992f85e495f873e53a7e' [nativecode=1146 ** Table 'markporter_co_uk.session' doesn't exist] in /home/httpd/vhosts/markporter.co.uk/httpdocs/mail/program/include/rcube_db.inc on line 455
[13-Jul-2006 08:48:05] PHP Fatal error: Call to a member function on a non-object in /home/httpd/vhosts/markporter.co.uk/httpdocs/mail/program/include/rcube_db.inc on line 343
[13-Jul-2006 11:12:40 +0100] DB Error: DB Error: no such table Query: SELECT vars, ip, UNIX_TIMESTAMP(changed) AS changed FROM session WHERE sess_id='bdefe136653ef872dfe6dadc7075b123' [nativecode=1146 ** Table 'markporter_co_uk.session' doesn't exist] in /home/httpd/vhosts/markporter.co.uk/httpdocs/mail/program/include/rcube_db.inc on line 455
[13-Jul-2006 11:12:40] PHP Fatal error: Call to a member function on a non-object in /home/httpd/vhosts/markporter.co.uk/httpdocs/mail/program/include/rcube_db.inc on line 343
[13-Jul-2006 15:00:24 +0100] DB Error: DB Error: no such table Query: SELECT vars, ip, UNIX_TIMESTAMP(changed) AS changed FROM session WHERE sess_id='cfdb9c8225911b7f92a7164951825c01' [nativecode=1146 ** Table 'markporter_co_uk.session' doesn't exist] in /home/httpd/vhosts/markporter.co.uk/httpdocs/mail/program/include/rcube_db.inc on line 455
[13-Jul-2006 15:00:24] PHP Fatal error: Call to a member function on a non-object in /home/httpd/vhosts/markporter.co.uk/httpdocs/mail/program/include/rcube_db.inc on line 343

Offline flosoft

  • Sr. Member
  • ****
  • Posts: 349
    • http://flosoft.biz
Re: Nothing Happens
« Reply #1 on: July 15, 2006, 07:04:05 AM »
Added code tags.

Offline jumpenjuhosaphat

  • Newbie
  • *
  • Posts: 1
Re: Nothing Happens
« Reply #2 on: July 20, 2006, 10:21:48 PM »
I'm having the same issue. I am running on Apache server, cPanel, MySql version 5.0.18-standard, PHP version 4.4.2

I changed the files specified in the config folder, then uploaded, went to index.php, and nothing, just a blank screen. Did I miss something?

Offline condenser

  • Newbie
  • *
  • Posts: 4
Re: Nothing Happens
« Reply #3 on: July 24, 2006, 04:47:22 AM »
i've got the same problem
looked for "blank page" on the forums but found no answers
please help!

Offline bpat1434

  • Administrator
  • Hero Member
  • *****
  • Posts: 673
Re: Nothing Happens
« Reply #4 on: July 24, 2006, 08:59:52 AM »
Well seems like the sessions table is missing from the SQL setup... which file did you execute: mySQL initial or mySQL Update? You want the initial one.

Then in the config files, is auto_create_user true or false? You want true at first to create the users, then you can restrict it.

It also looks like you have some connection errors in the mix with that.....

Best bet: Dump the entire database (drop all the tables). Then execute the mysql.initial.sql file from the 0.1b SQL folder. That should have everything you need. Then try again.
 
  

Offline markg85

  • Jr. Member
  • **
  • Posts: 17
Re: Nothing Happens
« Reply #5 on: July 31, 2006, 10:00:58 PM »
i had the same problem and i found my error.. though i think it`s also a error in the error reporting of this good looking script :) i did edited my db configuration and saved it... but apperently it wasn`t saved because when i looked in another time i still got the default pass... won`t work :)

But the error of this script is that it just stays silent.. it must point out that a connection can`t be made!! not just say nothing.. that`s bad!! :) o well.. i`m gonna try and login now and play with this eye candy script

@to the creators..
really wonderfull that you guys make such a buatifull script for free under the gpl licence :) good job so far!! O0

Offline bpat1434

  • Administrator
  • Hero Member
  • *****
  • Posts: 673
Re: Nothing Happens
« Reply #6 on: July 31, 2006, 10:54:49 PM »
Well, it can show that there was an error, you just have to turn error reporting up. By default, it's set ot just log it so it gracefully fails ;)
 
  

Offline markporter

  • Newbie
  • *
  • Posts: 7
Re: Nothing Happens
« Reply #7 on: August 06, 2006, 05:46:34 PM »
<>

It was the initial one initially...though I did run the other one as well

<>

It's true

<>

Able to help a bit more on this one?

<>

I did this, and there's still this lovely blank page :-[

Offline bpat1434

  • Administrator
  • Hero Member
  • *****
  • Posts: 673
Re: Nothing Happens
« Reply #8 on: August 06, 2006, 05:52:20 PM »
Mark:

Beta 2 just came out, try giving that a shot.
 
  

Offline markporter

  • Newbie
  • *
  • Posts: 7
Re: Nothing Happens
« Reply #9 on: August 06, 2006, 06:23:07 PM »
ok, I'm up to beta 2 now, and I've changed the error logging method, so if you go to http://www.markporter.co.uk/mail/ you can see the error, it's still pretty much the same;

DB Error in /home/httpd/vhosts/markporter.co.uk/httpdocs/mail/program/include/rcube_db.inc (479): DB Error: no such table Query: SELECT vars, ip, UNIX_TIMESTAMP(changed) AS changed FROM session WHERE sess_id='1944873d2fcb28683e1b78c00f902384' [nativecode=1146 ** Table 'markporter_co_uk.session' doesn't exist]

Fatal error: Call to a member function on a non-object in /home/httpd/vhosts/markporter.co.uk/httpdocs/mail/program/include/rcube_db.inc on line 367

Offline bpat1434

  • Administrator
  • Hero Member
  • *****
  • Posts: 673
Re: Nothing Happens
« Reply #10 on: August 06, 2006, 06:27:32 PM »
I'm thinking something:
You changed the name of the mySQL table somehow and didn't update the db.inc.php file.

I got this error initially when I started putting different builds on the same site. I would separate the tables by buildNumber__tableName It worked, but I always had an issue of missing one table.

I'd suggest you open your phpMyAdmin and look at the table names. Also open your db.inc.php file and look at those names. And just to make sure, when you've verified the names are correct, overwrite the db.inc.php file and try again.

Other than that, I'd need FTP access to really get down to the nitty gritty to see what's going on.
 
  

Offline markporter

  • Newbie
  • *
  • Posts: 7
Re: Nothing Happens
« Reply #11 on: August 06, 2006, 08:30:34 PM »
hmm. tried renaming the tables and that didn't help. Think I'd rather not give FTP access, so guess I might have to leave it there.

Offline markporter

  • Newbie
  • *
  • Posts: 7
Re: Nothing Happens
« Reply #12 on: August 07, 2006, 08:56:24 AM »
Right...it's fixed now - I gave the thing to my hosting guys and they sorted it out for me, apparently the issues were as follows;

<1) add a line in the initial sql file that you have to run to make it use the right database.
2) removed the .htaccess file in the main directory as I don't believe it was critical and it was causing errors.>>

Offline bpat1434

  • Administrator
  • Hero Member
  • *****
  • Posts: 673
Re: Nothing Happens
« Reply #13 on: August 07, 2006, 09:00:55 AM »
Glad to hear you got it sorted.
 
  

Offline NapkinSketch

  • Newbie
  • *
  • Posts: 3
Re: Nothing Happens
« Reply #14 on: August 08, 2006, 03:36:46 AM »
Can you give me some insight into what was added to the sql file? I am having the same problem and I have deleted the .htaccess files and played with the hostname but I still get a blank screen. Thanks!