Author Topic: Upgrade Script 0.8.5 to 0.9.5  (Read 2661 times)

Offline gobokster

  • Newbie
  • *
  • Posts: 1
Upgrade Script 0.8.5 to 0.9.5
« on: October 24, 2013, 10:01:46 PM »
Hello,

i just updating my roundcubemail 0.8.5 to 0.9.5, everything went well on the upgrade process following a guide from http://trac.roundcube.net/wiki/Howto_Upgrade, but at the end of the updating it appear an error

Quote
Do you want me to fix your local configuration? (y/N)
y
. backing up the current config files...
. writing /usr/share/apache2/roundcubemail-0.8.2/config/main.inc.php...
. writing /usr/share/apache2/roundcubemail-0.8.2/config/main.db.php...
Done.
Your configuration files are now up-to-date!
Executing database schema update.
ERROR: Error in DDL upgrade 2012080700: [1142] ALTER command denied to user 'roundcube'@'localhost' for table 'cache'Updating database schema (2012080700)... [FAILED]
All done.

should i be worried by this error or malfunction of roundcubemail.

i suspect the error caused by forgetting to edit the credentials of the file config/db.inc.php.dist, but when i check the roundcubemail About, it appear to be on version 0.9.5, not sure how to check the db schema were updated or not,   .. after edited the  file with db  credentials, i tried to execute the upgrade script again but it wouldn't allowed me to, with the messages,
Quote
ERROR: Installation at target location is up-to-date!root@mail:~/roundcubemail-0.9.5

is there a way that i can cleanly re execute the upgrade script in order to get successfully upgraded roundcube 0.9.5 without an error,  8)

thank in advanced