Author Topic: Issue with NET/IDNA2  (Read 6964 times)

Offline tiyeb

  • Newbie
  • *
  • Posts: 5
Issue with NET/IDNA2
« on: November 06, 2013, 05:40:45 AM »
I' m using Ubuntu server 12.04 tls, and trying to use it as email server, i think i have configured postfix well, but i needed interfaces to handle creating messages and so on, i have this problem  during the installation of roundcube "i think the version is 0.9.5, but I' m not sure!!  because i installed it maybe more than once" , i don't know how to fix it,
an other question is about mx record would it be set automatically with roundcube?...
the following error is what i found:
//////////////////
Check for required 3rd party libs

This also checks if the include path is set correctly.
PEAR:  OK
MDB2:  OK
Net_SMTP:  OK
Warning: include_once(Net/IDNA2.php): failed to open stream: No such file or directory in /var/www/webmail/installer/utils.php on line 55 Warning: include_once(): Failed opening 'Net/IDNA2.php' for inclusion (include_path='/var/www/webmail/program/lib:/var/www/webmail/program:/var/www/webmail/program/include:.:/usr/share/php:/usr/share/pear') in /var/www/webmail/installer/utils.php on line 55 Net_IDNA2:  NOT OK(Failed to load Net/IDNA2.php; See http://pear.php.net/package/Net_IDNA2)
Mail_mime:  OK

//////////

i went to the proposed site but what to do next? ,should i download the package, how would i be able to add it to the library or put it in the right place, thank you guys in advance.

Offline tiyeb

  • Newbie
  • *
  • Posts: 5
Re: Issue with NET/IDNA2
« Reply #1 on: November 06, 2013, 10:23:59 AM »
Me again, this problem of this installation is on my desktop from the last weekend, i have not find the solution yet, i have tried to reinstall every thing including php, apache, even postfix , but this issue with roundcube is still missing, this is the full details:
////////////
Checking PHP version
Version:  OK(PHP 5.3.10-1ubuntu3.8 detected)
Checking PHP extensions

The following modules/extensions are required to run Roundcube:
PCRE:  OK
DOM:  OK
Session:  OK
XML:  OK
JSON:  OK

The next couple of extensions are optional and recommended to get the best performance:
FileInfo:  OK
Libiconv:  OK
Multibyte:  OK
OpenSSL:  OK
Mcrypt:  OK
Intl:  OK
Exif:  OK
Checking available databases

Check which of the supported extensions are installed. At least one of them is required.
MySQL:  OK
MySQLi:  OK
PostgreSQL:  NOT AVAILABLE(Not installed)
SQLite (v2):  NOT AVAILABLE(Not installed)
Check for required 3rd party libs

This also checks if the include path is set correctly.
PEAR:  OK
MDB2:  OK
Net_SMTP:  OK
Warning: include_once(Net/IDNA2.php): failed to open stream: No such file or directory in /var/www/webmail/installer/utils.php on line 55 Warning: include_once(): Failed opening 'Net/IDNA2.php' for inclusion (include_path='/var/www/webmail/program/lib:/var/www/webmail/program:/var/www/webmail/program/include:.:/usr/share/php:/usr/share/pear') in /var/www/webmail/installer/utils.php on line 55 Net_IDNA2:  NOT OK(Failed to load Net/IDNA2.php; See http://pear.php.net/package/Net_IDNA2)
Mail_mime:  OK
Checking php.ini/.htaccess settings

The following settings are required to run Roundcube:
file_uploads:  OK
session.auto_start:  OK
zend.ze1_compatibility_mode:  OK
mbstring.func_overload:  OK
suhosin.session.encrypt:  OK
magic_quotes_runtime:  OK
magic_quotes_sybase:  OK
date.timezone:  OK

The following settings are optional and recommended:
allow_url_fopen:  OK

//////////////////////////

 any help is appreciated. Thanks. 
« Last Edit: November 06, 2013, 01:41:12 PM by tiyeb »

Offline SKaero

  • Administrator
  • Hero Member
  • *****
  • Posts: 5,566
    • http://SKaero.com/
Re: Issue with NET/IDNA2
« Reply #2 on: November 06, 2013, 05:48:11 PM »
Are you using the GPL (dependent) version of RoundCube?

Offline tiyeb

  • Newbie
  • *
  • Posts: 5
Re: Issue with NET/IDNA2
« Reply #3 on: November 07, 2013, 04:14:30 AM »
Thank you,
I'm installing roundcubemail-0.9.5, no thing  written about GPL, I think it is the standard version.

Offline tiyeb

  • Newbie
  • *
  • Posts: 5
Re: Issue with NET/IDNA2
« Reply #4 on: November 07, 2013, 04:26:32 AM »
I'm sorry, i think that i have changed the installer index.php page from the Internet during my attempts, it is included with the attachments.



Thanks.

Offline SKaero

  • Administrator
  • Hero Member
  • *****
  • Posts: 5,566
    • http://SKaero.com/
Re: Issue with NET/IDNA2
« Reply #5 on: November 07, 2013, 05:20:33 AM »
That installer page is from RoundCube 0.6, make sure your using the installer for 0.9.5.

Offline tiyeb

  • Newbie
  • *
  • Posts: 5
Re: Issue with NET/IDNA2
« Reply #6 on: November 07, 2013, 05:44:15 AM »
Ok, i will try to find that one.   

thank you very much SKaero.