Author Topic: 0.1rc1 - can't send mails  (Read 7614 times)

Offline yathosho

  • Newbie
  • *
  • Posts: 5
0.1rc1 - can't send mails
« on: May 20, 2007, 07:44:21 AM »
just upgraded from 0.1beta2 to rc1 - i cannot send emails anymore. the dropdown menu on top of the page is empty (i don't recall that menu in the beta). everything worked fine before. the only change i did (when running beta2) was adding aliases to my logins. any clue?

Offline smcallah

  • Newbie
  • *
  • Posts: 4
Re: 0.1rc1 - can't send mails
« Reply #1 on: May 20, 2007, 01:29:17 PM »
I have the same problem too.

The Sender drop down box is empty and the mail will not send. I can't compose new emails or reply to emails.

I think I'm going to have to back out to beta2. This is the 2nd killer bug. The other is when you do a ctrl-click to select multiple emails and it will open a new tab for each email you click in Firefox and IE.

Offline zeb

  • Newbie
  • *
  • Posts: 4
Re: 0.1rc1 - can't send mails
« Reply #2 on: May 20, 2007, 07:48:49 PM »
Did you read the UPGRADING instructions? You need to upgrade your database. I've just done it and it works fine.

HTH.

Offline smcallah

  • Newbie
  • *
  • Posts: 4
Re: 0.1rc1 - can't send mails
« Reply #3 on: May 20, 2007, 11:45:39 PM »
Yes, I read the UPGRADING instructions. And followed them to the end for beta2, which I had previously installed.

And no, my mail sending is not working.

Thanks for your helpful reply.

I would not be asking here if I did not follow the UPGRADING instructions.

Offline zeb

  • Newbie
  • *
  • Posts: 4
Re: 0.1rc1 - can't send mails
« Reply #4 on: May 21, 2007, 03:59:52 AM »
You didn't say in your original post that you'd followed the instructions. I speak from experience - I didn't upgrade the database and the drop-down was blank. I then ran the upgrade SQL and there it was, populated with my preferences.

Hope you find the solution soon.

Offline yathosho

  • Newbie
  • *
  • Posts: 5
Re: 0.1rc1 - can't send mails
« Reply #5 on: May 24, 2007, 02:50:30 PM »
i also upgraded the database using the sql file. does roundcube have a prefered mysql version to run on?

Offline SKaero

  • Administrator
  • Hero Member
  • *****
  • Posts: 5,491
    • http://SKaero.com/
Re: 0.1rc1 - can't send mails
« Reply #6 on: May 24, 2007, 03:41:58 PM »
you can use a mysql version from 4.0.x up, but I don't know about any preferred mysql version.

Offline yathosho

  • Newbie
  • *
  • Posts: 5
Re: 0.1rc1 - can't send mails
« Reply #7 on: May 24, 2007, 04:21:57 PM »
upgraded mysql from 3.x to 4.x, but the problem persists :(

Offline ludatbooick

  • Newbie
  • *
  • Posts: 8
Re: 0.1rc1 - can't send mails
« Reply #8 on: May 25, 2007, 11:16:08 AM »
I am having a similar problem but i started from a clean install of the database. i get the account name but i get an error on the page when trying to send:

Line: 1684
Char: 5
Error: 'tinyMCE' is undefined
Code: 0

Any ideas? Thanks!

*edit* This only happens when the message body is blank. i narrowed it down to the file program\js\app.js where it checks for an empty message:

// check for empty body
  if ((input_message.value=='')&&(tinyMCE.getContent()==''))
   {
   if (!confirm(this.get_label('nobodywarning')))
    {
    input_message.focus();
    return false;
    }
   }

  return true;
  };

Offline hoferchr

  • Jr. Member
  • **
  • Posts: 10
Re: 0.1rc1 - can't send mails
« Reply #9 on: May 26, 2007, 12:46:30 AM »
I am having many of the same issues that have already been described. When I go into my myPhpAdmin section to import the newest version of "mysql.update.sql" from the "SQL" folder, I receive the following message:

~~~~~~~~~~
Error

SQL query:

-- RoundCube Webmail update script for MySQL databases
-- Updates from version 0.1-beta and 0.1-beta2

ALTER TABLE `messages` DROP `body` ,
DROP INDEX `cache_key` ,
ADD `structure` TEXT,
ADD UNIQUE `uniqueness` ( `user_id` , `cache_key` , `uid` ) ;

MySQL said:
#1062 - Duplicate entry '5-INBOX.Sent.msg-154' for key 2

~~~~~~~~~~

Any help would be great!

Offline rockwilda

  • Jr. Member
  • **
  • Posts: 35
Re: 0.1rc1 - can't send mails
« Reply #10 on: May 26, 2007, 06:27:56 AM »
Quote from: hoferchr
Error

SQL query:

-- RoundCube Webmail update script for MySQL databases
-- Updates from version 0.1-beta and 0.1-beta2

ALTER TABLE `messages` DROP `body` ,
DROP INDEX `cache_key` ,
ADD `structure` TEXT,
ADD UNIQUE `uniqueness` ( `user_id` , `cache_key` , `uid` ) ;

MySQL said:
#1062 - Duplicate entry '5-INBOX.Sent.msg-154' for key 2


I had the same issue. I truncated the table messages and the update worked.

sql command is
Code: [Select]
TRUNCATE TABLE 'messages'
The table messages contains the chached messages ...

Nico




Offline rtomanek

  • Newbie
  • *
  • Posts: 8
Re: 0.1rc1 - can't send mails
« Reply #11 on: May 26, 2007, 07:07:40 AM »
Hi,

 That's it, I had the same problem, just truncated (cleared) the table and the problem went away. 'Message cache' did not sound too important, but someone could actually confirm truncating the table was harmless.

 After doing so, my installation works perfect (as far as I can tell).

Regards,
r.

Offline yathosho

  • Newbie
  • *
  • Posts: 5
Re: 0.1rc1 - can't send mails
« Reply #12 on: May 26, 2007, 08:03:37 AM »
thanks, works for me aswell

Offline hoferchr

  • Jr. Member
  • **
  • Posts: 10
Re: 0.1rc1 - can't send mails
« Reply #13 on: May 26, 2007, 11:07:24 AM »
That worked for me as well, thank you!