Author Topic: [SOLVED]could not install by "click next"  (Read 11806 times)

Offline sorryboy

  • Jr. Member
  • **
  • Posts: 23
[SOLVED]could not install by "click next"
« on: January 02, 2014, 12:48:15 AM »
Hi everyone

I have a problem about install,when I go to http://mydomain/roundcube/installer,
something confuse me,in the  "Check environment" page, I finish all requirement and no "red" with "not ok" appear,
and when I clicked "next",there is nothing happen,the page still in "Check environment",and no errors occurred 。
I checked the log file and apache error log ,and find nothing,how cloud I fixed this problm,thanks。

I also tried to install by extract roundcube.tar.gz to my web path (ex:/usr/local/www/roundcube),I can log in ,but still have a problem,
when I clicked message box or sent message box ,the error occurred with "Server failed" ,I checked log file , there is a error with this below:
[02-Jan-2014 11:54:57 +0800]: PHP Error: Error loading template for  in /usr/local/www/apache22/data/roundcube/program/include/rcmail_output_html.php on line 489 (GET /rcmail/?_task=mail&_action=getunread&_remote=1&_unlock=0&_=1388634897622)
I sure the temp directory is 777
#ls -ld /usr/local/www/apache22/data/roundcube/temp/
drwxrwxrwx  2 root  wheel  512 10 22 03:39 /usr/local/www/apache22/data/roundcube/temp/

I also sure my postfix and IMAP are correct,because openwebmail and outlook2010 can work with same postfix and IMAP setting
Cloud every one give me some suggestion ,thanks a lot
My server is   FreeBSD 9.1-RELEASE-p3
« Last Edit: March 25, 2014, 03:32:48 AM by sorryboy »

Offline SKaero

  • Administrator
  • Hero Member
  • *****
  • Posts: 5,644
    • http://SKaero.com/
Re: could not install by "click next"
« Reply #1 on: January 02, 2014, 03:33:03 AM »
From the error your getting I would tend to say that your installation is missing files.

Offline sorryboy

  • Jr. Member
  • **
  • Posts: 23
Re: could not install by "click next"
« Reply #2 on: January 02, 2014, 03:58:28 AM »
Very thans for your reply
what is the missing file that I need,I guess is php,beause when I using freebsd ports to install the error message below :
pkg_add: could not find package php5-5.4.13 !
*** [install-package] Error code 1

Stop in /usr/ports/mail/roundcube.
*** [install] Error code 1

but I am sure that I have been install all php requirement

php55-5.5.7         PHP Scripting Language
php55-bcmath-5.5.7  The bcmath shared extension for php
php55-bz2-5.5.7     The bz2 shared extension for php
php55-calendar-5.5.7 The calendar shared extension for php
php55-ctype-5.5.7   The ctype shared extension for php
php55-curl-5.5.7    The curl shared extension for php
php55-dba-5.5.7     The dba shared extension for php
php55-dom-5.5.7     The dom shared extension for php
php55-exif-5.5.7    The exif shared extension for php
php55-extensions-1.8 A "meta-port" to install PHP extensions
php55-fileinfo-5.5.7 The fileinfo shared extension for php
php55-filter-5.5.7  The filter shared extension for php
php55-ftp-5.5.7     The ftp shared extension for php
php55-gd-5.5.7      The gd shared extension for php
php55-gettext-5.5.7 The gettext shared extension for php
php55-gmp-5.5.7     The gmp shared extension for php
php55-hash-5.5.7    The hash shared extension for php
php55-iconv-5.5.7   The iconv shared extension for php
php55-imap-5.5.7    The imap shared extension for php
php55-json-5.5.7    The json shared extension for php
php55-mbstring-5.5.7 The mbstring shared extension for php
php55-mcrypt-5.5.7  The mcrypt shared extension for php
php55-mssql-5.5.7   The mssql shared extension for php
php55-mysql-5.5.7   The mysql shared extension for php
php55-opcache-5.5.7 The opcache shared extension for php
php55-openssl-5.5.7 The openssl shared extension for php
php55-pcntl-5.5.7   The pcntl shared extension for php
php55-pdo-5.5.7     The pdo shared extension for php
php55-pdo_mysql-5.5.7 The pdo_mysql shared extension for php
php55-pdo_pgsql-5.5.7 The pdo_pgsql shared extension for php
php55-pdo_sqlite-5.5.7 The pdo_sqlite shared extension for php
php55-pgsql-5.5.7   The pgsql shared extension for php
php55-phar-5.5.7    The phar shared extension for php
php55-posix-5.5.7   The posix shared extension for php
php55-pspell-5.5.7  The pspell shared extension for php
php55-readline-5.5.7 The readline shared extension for php
php55-session-5.5.7 The session shared extension for php
php55-shmop-5.5.7   The shmop shared extension for php
php55-simplexml-5.5.7 The simplexml shared extension for php
php55-snmp-5.5.7    The snmp shared extension for php
php55-soap-5.5.7    The soap shared extension for php
php55-sockets-5.5.7 The sockets shared extension for php
php55-sysvmsg-5.5.7 The sysvmsg shared extension for php
php55-sysvsem-5.5.7 The sysvsem shared extension for php
php55-sysvshm-5.5.7 The sysvshm shared extension for php
php55-tidy-5.5.7    The tidy shared extension for php
php55-tokenizer-5.5.7 The tokenizer shared extension for php
php55-wddx-5.5.7    The wddx shared extension for php
php55-xml-5.5.7     The xml shared extension for php
php55-xmlreader-5.5.7 The xmlreader shared extension for php
php55-xmlrpc-5.5.7  The xmlrpc shared extension for php
php55-xmlwriter-5.5.7 The xmlwriter shared extension for php
php55-xsl-5.5.7     The xsl shared extension for php
php55-zip-5.5.7     The zip shared extension for php
php55-zlib-5.5.7    The zlib shared extension for php

Did Anything I missed that is roundcube needed?
I have no idea about this errors......

Offline SKaero

  • Administrator
  • Hero Member
  • *****
  • Posts: 5,644
    • http://SKaero.com/
Re: could not install by "click next"
« Reply #3 on: January 02, 2014, 04:24:45 AM »
The error from the ports is because you using PHP 5.5 and the package requires PHP 5.4 but RoundCube will work fine with PHP 5.5 so that shouldn't be the problem. There should be an error log somewhere (Apache's maybe?) that would shed some more light on the problem.

Offline sorryboy

  • Jr. Member
  • **
  • Posts: 23
Re: could not install by "click next"
« Reply #4 on: January 02, 2014, 05:03:26 AM »
thanks for your reply
I checked the error log of apache error log and roundcube log file ,but nothing happened,
there is no error message writed

I using tail -f /var/log/apapche/2014-01-02_access.log to observe
and the message is below
10.0.0.55 - - [02/Jan/2014:17:59:02 +0800] "GET /r/installer/index.php?_step=2 HTTP/1.1" 200 4564 "http://192.168.1.20/r/installer/index.php?_step=2" "Mozilla/5.0 (Windows NT 6.1; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/31.0.1650.63 Safari/537.36"

I think this is a common message.....
what is the direction should I go

Offline SKaero

  • Administrator
  • Hero Member
  • *****
  • Posts: 5,644
    • http://SKaero.com/
Re: could not install by "click next"
« Reply #5 on: January 02, 2014, 08:06:27 AM »
Is there any way you could let me access the installation?

Offline sorryboy

  • Jr. Member
  • **
  • Posts: 23
Re: could not install by "click next"
« Reply #6 on: January 02, 2014, 07:15:19 PM »
Thanks for your reply
Is that your meaning to access by http://public.ip/roundcube/installer ?
or you needed to access my system

Offline SKaero

  • Administrator
  • Hero Member
  • *****
  • Posts: 5,644
    • http://SKaero.com/
Re: could not install by "click next"
« Reply #7 on: January 02, 2014, 11:02:11 PM »
I just need access to the installer for now, hopefully that gives us a better direction.

Offline SKaero

  • Administrator
  • Hero Member
  • *****
  • Posts: 5,644
    • http://SKaero.com/
Re: could not install by "click next"
« Reply #8 on: January 03, 2014, 01:21:19 AM »
Thanks for the email, I've looked at your system and I don't see anything obviously wrong. My hunch is that your $_REQUEST variable is empty, RoundCube uses the $_REQUEST variable to get the  '_step' parameter and if its not there it will always display the first page.

Try editing the <RC root>/installer/rcube_install.php and replacing $_REQUEST['_step'] with $_GET['_step'] and see it that lets you get to the next step.

Offline sorryboy

  • Jr. Member
  • **
  • Posts: 23
Re: could not install by "click next"
« Reply #9 on: January 03, 2014, 02:06:04 AM »
thanks for your reply
,It  can "next" now !!! ,you are so genius, I am so amazing~
I think the "server failed after login" could be solved after normal  installation
thanks you again ^^

Offline sorryboy

  • Jr. Member
  • **
  • Posts: 23
Re: could not install by "click next"
« Reply #10 on: January 03, 2014, 02:36:36 AM »
The step 2 "Create Config" is ok,but when I clicked "Create Config" it go back to step1....
should I change other $_REQUEST['_step'] with $_GET['_step'] in other config file ? thanks

Offline JohnDoh

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 2,539
Re: could not install by "click next"
« Reply #11 on: January 03, 2014, 02:58:44 AM »
please look in your php.ini file and check the values of the request_order and variables_order directives. Roundcube needs request_order to be 'GP' at least I think.
Roundcube Plugins: Contextmenu, SpamAssassin Prefs, and more…

Offline sorryboy

  • Jr. Member
  • **
  • Posts: 23
Re: could not install by "click next"
« Reply #12 on: January 03, 2014, 05:20:54 AM »
thanks for your reply
I change "request_order=GP" and "variables_order=GPCS with php.ini ,but it still go back to step1

Offline SKaero

  • Administrator
  • Hero Member
  • *****
  • Posts: 5,644
    • http://SKaero.com/
Re: could not install by "click next"
« Reply #13 on: January 03, 2014, 07:28:46 AM »
Did you restart the web server after making the changes?

Offline JohnDoh

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 2,539
Re: could not install by "click next"
« Reply #14 on: January 03, 2014, 08:07:32 AM »
you changed it ... what was it before?

did you put the values in quotes? i think you have too. may be get a php_info output from the same directory as roundcube to check what values the server is actually using?
Roundcube Plugins: Contextmenu, SpamAssassin Prefs, and more…