Author Topic: Can't send mails  (Read 4737 times)

Offline Alexismoy

  • Newbie
  • *
  • Posts: 7
Can't send mails
« on: June 21, 2007, 03:58:14 AM »
Hi,

I'm having troubles.

I have the last version of roundcubemail (the rc-1), and sometimes I can't log in, but for exemple, 20 minuts after, I can.
And I can't send mails (never).

I've already the last version (beta), and when I can't log in with the rc-1, I can with the beta. I can send mails with the beta (always).

Any idea? Someone have got the same problem?

Thanks for your help.

Offline Florianer

  • Full Member
  • ***
  • Posts: 102
Re: Can't send mails
« Reply #1 on: June 21, 2007, 04:09:57 AM »
Hi,
which mail provider do you use? What are the settings you made for the mail config?
it\'s not a bug - it\'s a feature


Offline Alexismoy

  • Newbie
  • *
  • Posts: 7
Re: Can't send mails
« Reply #2 on: June 21, 2007, 06:40:53 AM »
I'm using mine.

The settings are the same that in the beta's roundcubemail config.

server mail is in localhost
no autentication (the local network is trust by the mail server)

In the beta roundcubemail, it's working
In the rc-1 version, it doesn´t work

Offline SKaero

  • Administrator
  • Hero Member
  • *****
  • Posts: 5,536
    • http://SKaero.com/
Re: Can't send mails
« Reply #3 on: June 21, 2007, 01:28:05 PM »
are there any errors in the error log?

Offline Alexismoy

  • Newbie
  • *
  • Posts: 7
Re: Can't send mails
« Reply #4 on: June 21, 2007, 02:17:51 PM »
The error message is:

[Thu Jun 21 20:12:05 2007] [error] [client xx.xxx.xx.xx] PHP Notice: SMTP error: No From address has been provided in /var/www/roundcubemail-rc1/program/include/bugs.inc on line 80, referer: https://webmail.xxx.yy/?_task=mail&_action=compose

Offline Alexismoy

  • Newbie
  • *
  • Posts: 7
Re: Can't send mails
« Reply #5 on: June 22, 2007, 01:52:58 AM »
When I try to send a mail, I can't choose From which Identity I would like to send it. The case is empty and no selection is possible.

Maybe it's because I've got only 1 identity, but the error message tells that I haven't got selected From which address I send the mail.

I've got an other problem, I don't know if I need to make a new post for it?
The other problem is I cannot edit an identity. I can just create an new one and delete the other one, but if I try to edit an identity, and I save it, changes are not saved.

Thanks for your help.

Offline SKaero

  • Administrator
  • Hero Member
  • *****
  • Posts: 5,536
    • http://SKaero.com/
Re: Can't send mails
« Reply #6 on: June 22, 2007, 05:41:49 AM »
For the Identity problem: http://roundcubeforum.net/forum/index.php?topic=1485.0as for the SMTP
Did you do a fresh install of upgrade to RC1?

Offline Alexismoy

  • Newbie
  • *
  • Posts: 7
Re: Can't send mails
« Reply #7 on: June 22, 2007, 05:54:11 AM »
I think the problem is that I didn't followed tutorials.

I'v installed the rc version without changing nothing in the data base used by the beta version.
I was just trying it before changing defenitively to it.

Is that my problem? If yes, I will search for documentation.


Thanks

Offline SKaero

  • Administrator
  • Hero Member
  • *****
  • Posts: 5,536
    • http://SKaero.com/
Re: Can't send mails
« Reply #8 on: June 22, 2007, 11:40:46 PM »
YES you have to update the database. Read the UPGRADING document to find out how.

Offline Alexismoy

  • Newbie
  • *
  • Posts: 7
Re: Can't send mails
« Reply #9 on: June 23, 2007, 04:41:30 AM »
Thanks,

now it's done and everything works fine.

Sorry for this post. I didn't read the documentation, it's all my fault.