Roundcube Community Forum


SMTP Error - Unable to send email

Started by unixgolf, July 22, 2007, 05:10:31 PM

Previous topic - Next topic


I have had Roundcube for a long time working flawlessly, but within the last few days I have been unable to send email, (receiving and viewing emails fine) the following message appears in the error log:

SMTP Error: SMTP error: Authentication failure: SMTP server does no support authentication
 in /homepages/xx/xxxxxxxxx/htdocs/xxxxxxx/rcube/program/steps/mail/ on line 253.

I use 1and1 (US) as my provider. I know it probably isn't a Roundcube issue, but I am trying to figure out where to start looking at the issue??



Just a small update, in the file I removed the smtp server ( and left it blank thus forcing RC to use PHP mail() to send mail, which seems to work. Buy I would rather be using smtp.....Any input would be apprciated!



i'm also trying to setup roundcube on a 1&1 account with no luck.
i've tried all of the authentication options but still get authentication errors while trying to send e-mails.
anyone have any ideas?


The SMTP server should be set up like you have in say Thunderbird or Outlook or Apple Mail or Eudora etc. So if you have to authenticate with 1&1, you may want to ask them what authentication method they're using (or even what mail server: Cyrus, Postfix, etc.) so that maybe we can add an authentication method for it or figure out what's wrong.


I had the same problem with my 1and1 setup. I think i found out the issue.

It was to do with open ports with my hosting company. The SSL port that 1and1 require when connecting to their smtp server was not open outbound with my hosting ISP. I contacted support and after it was opened on my virtual server, i could connect fine.
I also tested over port25 (which was already open) with a different smtp server, and it worked to.

In the end, my virtual server has it's own SMTP service with AUTH, so i just changed smtp= to localhost.




I set up a Postfix instance to relay mail to a different MTA for actual delivery, and then set up RoundCube (and any other MUA) to send to that Postfix instance. I am sure Postfix can connect to 1&1 via standard authentication mechanisms.

Hope that helps,


i've got the same problem with 1&1 in Germany.
It works fine to poll mails with Imap and send with the mail() function, but i'm still trying to sort out sending via SMTP and also poll via IMAP SSL.


If you are using 1&1 and getting the "Authentication failure: SMTP server does no support authentication", try this. Remove the username and password from the smtp config. It worked for me. Makes me cringe that you can connect without them, but it works. At least for now!