Author Topic: Not loading Sub Folders or default folders for one account. Others work fine.  (Read 1929 times)

Offline benhjoz

  • Newbie
  • *
  • Posts: 6
Hi,

First thanks for reading.

I have an issue with one account on my instance of Roundcube. I am using release 1.0.1

Set up RC out the box then added in namespaces and logged in with two accounts and they work fine. Each of these accounts are on the same mail/IMAP servers. RC logs in really quickly and loads all folders, defaults, subscribed etc....

However one of the accounts that will be using this instance the most only loads the inbox but does not include default folders or any messages that are outside the parent tree INBOX. This particular account is on the same server that another of the accounts work fine from.

Does anyone know why it fails to list any other folders and takes over a minute to login and is then slow anytime it accesses the IMAP server? I have tailed the logs and everytime this particular account runs slowly and(or) fails to load beyond comand is when it is authenticating against the IMAP server.

To be fair the mailbox in question is huge, very huge. 15000+ folders. I have suspected timeout issues and if this is the case does can something be tweaked so that things are at least listed or something?

Many thanks,

B

Offline alec

  • Hero Member
  • *****
  • Posts: 1,159
To be fair the mailbox in question is huge, very huge. 15000+ folders.
Enable imap_debug in Roundcube to see if the server response is slow or it's a problem in Roundcube code. Folders list sorting might be a culprit indeed. We recently fixed it in git-master version. You could try it to at least see if it fixes the issue.

Offline benhjoz

  • Newbie
  • *
  • Posts: 6
Thanks for your reply.

I have downloaded and configured the Git-master.
Issue for this particular mailbox still exists.
The IMAP log shows this for the user with the huge mailbox with loads of folders:-

[13-Jun-2014 10:25:33 +0000]: [CFF5] C: A0002 STATUS INBOX (MESSAGES UNSEEN)
[13-Jun-2014 10:25:33 +0000]: [CFF5] S: * STATUS "INBOX" (MESSAGES 290 UNSEEN 273)
[13-Jun-2014 10:25:33 +0000]: [CFF5] S: A0002 OK STATUS Completed.
[13-Jun-2014 10:25:33 +0000]: [CFF5] C: A0003 SELECT INBOX
[13-Jun-2014 10:25:34 +0000]: [CFF5] S: * FLAGS ($Forwarded \Draft \Answered \Flagged \Deleted \Seen \Recent)
[13-Jun-2014 10:25:34 +0000]: [CFF5] S: * OK [PERMANENTFLAGS ($Forwarded \* \Draft \Answered \Flagged \Deleted \Seen)] Limited
[13-Jun-2014 10:25:34 +0000]: [CFF5] S: * 290 EXISTS
[13-Jun-2014 10:25:34 +0000]: [CFF5] S: * 79 RECENT
[13-Jun-2014 10:25:34 +0000]: [CFF5] S: * OK [UIDVALIDITY 1139416314] Ok
[13-Jun-2014 10:25:34 +0000]: [CFF5] S: * OK [MYRIGHTS "acdilrsw"] ACL
[13-Jun-2014 10:25:34 +0000]: [CFF5] S: A0003 OK [READ-WRITE] Ok
[13-Jun-2014 10:25:34 +0000]: [CFF5] C: A0004 UID SEARCH 290
[13-Jun-2014 10:25:34 +0000]: [CFF5] S: * SEARCH 1626257

[13-Jun-2014 10:25:34 +0000]: [CFF5] S: A0004 OK SEARCH done.
[13-Jun-2014 10:25:34 +0000]: [CFF5] C: A0005 UID SEARCH ALL


****
And this for a much much smaller mailbox with not so many folders:-

[13-Jun-2014 10:38:20 +0000]: [E290] S: A0001 OK LOGIN Ok.
[13-Jun-2014 10:38:20 +0000]: [E290] C: A0002 LSUB "" "*"
[13-Jun-2014 10:38:20 +0000]: [E290] S: * LSUB (\HasNoChildren) "." "INBOX.yy"
[13-Jun-2014 10:38:20 +0000]: [E290] S: * LSUB (\HasNoChildren) "." "INBOX.xx"
[13-Jun-2014 10:38:20 +0000]: [E290] S: * LSUB (\HasNoChildren) "." "INBOX.yy"
[13-Jun-2014 10:38:20 +0000]: [E290] S: * LSUB (\HasNoChildren) "." "INBOX.xx"
[13-Jun-2014 10:38:20 +0000]: [E290] S: * LSUB (\HasNoChildren) "." "INBOX.yy"
[13-Jun-2014 10:38:20 +0000]: [E290] S: * LSUB (\HasNoChildren) "." "INBOX.xx"
[13-Jun-2014 10:38:20 +0000]: [E290] S: * LSUB (\HasChildren) "." "INBOX.yy"
[13-Jun-2014 10:38:20 +0000]: [E290] S: * LSUB (\HasNoChildren) "." "INBOX.xx"
[13-Jun-2014 10:38:20 +0000]: [E290] S: * LSUB (\HasChildren) "." "INBOX.yy"
[13-Jun-2014 10:38:20 +0000]: [E290] S: * LSUB (\HasNoChildren) "." "INBOX.Drafts"
[13-Jun-2014 10:38:20 +0000]: [E290] S: * LSUB (\HasNoChildren) "." "INBOX.Queue"
[13-Jun-2014 10:38:20 +0000]: [E290] S: * LSUB (\HasNoChildren) "." "INBOX.xx"
[13-Jun-2014 10:38:20 +0000]: [E290] S: * LSUB (\HasNoChildren) "." "INBOX.Sent"
[13-Jun-2014 10:38:20 +0000]: [E290] S: * LSUB (\HasNoChildren) "." "INBOX.Trash"
[13-Jun-2014 10:38:20 +0000]: [E290] S: * LSUB (\Noselect \HasChildren) "." "INBOX"
[13-Jun-2014 10:38:20 +0000]: [E290] S: A0002 OK LSUB completed


Offline alec

  • Hero Member
  • *****
  • Posts: 1,159
This does not look like a complete log.

Offline benhjoz

  • Newbie
  • *
  • Posts: 6
Hi,

Threadsorting on the IMAP server has been disabled and timeout thresholds increased on client side / RC instance and this seems to now be loading, albeit slowly. For example the log file is now filling up with the names of the folders. I haven't progressed past login page yet but I can confirm the log is filling up so its just a case of waiting.

I don't think this is an issue pertaining to Roundcube per se but rather the almost inconceivabe and silly size of the mailbox in question and the default contraints of the timeout thresholds for all other things client side once threadsorting is not ocurring on the server. PHP, BROWSER and IMAP timeouts etc...

Many thanks for your help.