Author Topic: Returning to logonscreen  (Read 3734 times)

Offline oklona

  • Newbie
  • *
  • Posts: 4
Returning to logonscreen
« on: September 17, 2007, 07:02:23 AM »
Hello!
I have been trying for a few weeks now to get Roundcube running on my server. I have tried "everything". My client keeps returning to the login screen every time. I have tried turning on logging, and the only thing that shows up in the log is my IMAP server's reply as the user is successfully logged on.

I have also tried to put some debug messages into the code here and there, but I am now at a total loss of where to go to next. My server is not very new, but I am running PHP 4.4.2. I am running Courier IMAP on the same servere where RoundCube is installed. My RoundCube installation is installed to my Apache 2.0 at a subpath called "RoundCube", and it is secured by https.

So, if anybody has got any good suggestions, I am all ears :-)

Regards,

Ole Kristian

Offline SKaero

  • Administrator
  • Hero Member
  • *****
  • Posts: 5,536
    • http://SKaero.com/
Re: Returning to logonscreen
« Reply #1 on: September 17, 2007, 07:20:22 PM »
hmm so theres no errors in logs dir, are there any rows in the session table in the database?

Offline oklona

  • Newbie
  • *
  • Posts: 4
Re: Returning to logonscreen
« Reply #2 on: September 26, 2007, 04:32:31 AM »
Hello, I am very sorry I didn't check back until now!

No, there are no rows in the session table. However, the users table is updated to show my last login. -So at some point, Roundcube sees me as logged in, but somehow doesn't start the session. I have naturally made sure I accept cookies, and tried with different browsers.

Regards,

Ole Kristian

Offline SKaero

  • Administrator
  • Hero Member
  • *****
  • Posts: 5,536
    • http://SKaero.com/
Re: Returning to logonscreen
« Reply #3 on: September 26, 2007, 04:47:06 AM »
Ok can you do a test can you get login with this sever information, If you can't then we will know if its a roundcube, sever problem.

User name: demo@skaero.com
Password: password
Sever: mail.skaero.com


Offline oklona

  • Newbie
  • *
  • Posts: 4
Re: Returning to logonscreen
« Reply #4 on: September 26, 2007, 05:18:33 AM »
Thank you for your response :-) The result with your server was exactly the same. The log shows the CAPABILITY report, and ends showing that "Tried PLAIN: Resource ID #32". I believe PLAIN is one of the login-options I have enabled on the IMAP server.

Offline SKaero

  • Administrator
  • Hero Member
  • *****
  • Posts: 5,536
    • http://SKaero.com/
Re: Returning to logonscreen
« Reply #5 on: September 26, 2007, 05:24:25 AM »
hmm I am stumped, and theres no errors in roundcube log folder? It is wight able?

Offline oklona

  • Newbie
  • *
  • Posts: 4
Re: Returning to logonscreen
« Reply #6 on: September 26, 2007, 06:39:21 AM »
Well, it must be writable, as the IMAP messages do appear in the log, and are updated correctly. Also, since at least one table is updated in the database, permissions there shouldn't be a problem either.

Ole Kristian