Author Topic: Error upgrading from Version 0.1-beta2 to Version 0.1-rc1  (Read 4936 times)

Offline tazmanian

  • Newbie
  • *
  • Posts: 4
Error upgrading from Version 0.1-beta2 to Version 0.1-rc1
« on: October 02, 2007, 12:45:13 PM »
 I am trying to upgrade from from Version 0.1-beta2 to Version 0.1-rc1
and am receiving the following error when running the mysql.update.sql script. Can someone please tell
me how to fix this. thanks!
 
SQL query:
ALTER TABLE `messages` DROP `body` ,
DROP INDEX `cache_key` ,
ADD `structure` TEXT,
ADD UNIQUE `uniqueness` ( `user_id` , `cache_key` , `uid` ) ;



MySQL said:

#1062 - Duplicate entry '4-INBOX.msg-390' for key 2
 
and here is the script that was supplied to upgrade:
 

-- RoundCube Webmail update script for MySQL databases
-- Updates from version 0.1-beta and 0.1-beta2
 
ALTER TABLE `messages`
 DROP `body`,
 DROP INDEX `cache_key`,
 ADD `structure` TEXT,
 ADD UNIQUE `uniqueness` (`user_id`, `cache_key`, `uid`);
 
ALTER TABLE `identities`
 ADD `html_signature` tinyint(1) default 0 NOT NULL;
 
-- Uncomment these lines if you're using MySQL 4.1 or higher
ALTER TABLE `users`
DEFAULT CHARACTER SET utf8 COLLATE utf8_general_ci,
CHANGE `username` `username` VARCHAR( 128 ) CHARACTER SET utf8 COLLATE utf8_
general_ci NOT NULL,
CHANGE `alias` `alias` VARCHAR( 128 ) CHARACTER SET utf8 COLLATE utf8_genera
l_ci NOT NULL;

Offline apollo

  • Newbie
  • *
  • Posts: 1
Re: Error upgrading from Version 0.1-beta2 to Version 0.1-rc1
« Reply #1 on: October 02, 2007, 01:14:17 PM »
I got the same error, however RC1 is working great without these update.

I think the changes that should be made by that script are ment for upgrading from beta1 to beta2, not for beta2 to rc1. Theres another update-script which is needed for upgrading.
US World Domination Tour - bombing a country near you...

Offline benedikt

  • Newbie
  • *
  • Posts: 2
Re: Error upgrading from Version 0.1-beta2 to Version 0.1-rc1
« Reply #2 on: October 03, 2007, 03:24:56 AM »
I use ur thread as it is the same topic even not the same problem, ok?

I also wanted to upgrade my beta2 but after copying the index.php only, I can only see sth like this when I enter the URL in my Firefox:

‹������lQѪÛ0 }ïW¨†=6n ε$Þ$c…Þ¶d¹l{tb-1sí`«·-ìãç¤wcÃ…Â’=X–l)™Ǽþv*¡§³†ÓËÓ~—[pþ%Î9/ê¾~ªŸ÷°Š–P;a¼"eÐœ—¬'6œ_¯×èGÖu¼®ømµÁoî‚þBF’$ËfÉDx;kãÓÿ”Y­×ëÅ¡eIB)Ò˜Uöbd~iðç³P6PVÕ±‚÷Ë8ᏌY¢•ùuÊ<Ý5ú‘Ð}À”Þˆ·Þ3è~OÙàlçÄ™O™ÑôÁC þFÚXyÏf\4¡±N¢KÙ’A‹Z{1´ÊtâAHù;¾*I}ÊVËå»@…ªë)eB%ä‘ ´êLÊZ4„Ž$R½Ž“‰¡Õ‡¹ sÖ-&U,+¶õöiû¹|Þ@~<ʼÞðq»Û—Å<4üð<fÙ‹™…Öƒ-.õRiÂ㬓¬‹ áÃ8©©ëp“Ì‚q£¹¦·ÇøBca“Ù/���ÿÿ�µDq¹n��

I dont know where the problem is. I turned off safe_mode, I switched off MagicQuotes, but still...
I also downloaded from another sourceforge-server but I cant get it to work.

Is there any experience with this problem?

Offline SKaero

  • Administrator
  • Hero Member
  • *****
  • Posts: 5,517
    • http://SKaero.com/
Re: Error upgrading from Version 0.1-beta2 to Version 0.1-rc1
« Reply #3 on: October 03, 2007, 03:49:49 AM »
The errors should be fixed it do all of the steps,

  • replace index.php
  • replace all files in folder /program/
  • replace all files in folder /skins/default/
  • run all commands in SQL/*.update.sql or re-initalize database with *.initial.sql
  • add these lines to /config/main.inc.php

$rcmail_config['draft_autosave'] = 300;
$rcmail_config['date_today'] = 'H:i';
  • If you have LDAP servers configured, change prop key 'mail_field'

to 'email_field' for each server confgured in /config/main.inc.php
[/list]

Offline tazmanian

  • Newbie
  • *
  • Posts: 4
Re: Error upgrading from Version 0.1-beta2 to Version 0.1-rc1
« Reply #4 on: October 03, 2007, 10:11:53 AM »
I have done everything starting at step 1 including the following:
replace index.php
replace all files in folder /program/
replace all files in folder /skins/default/

it is at the next point that the problem from above begins.
run all commands in SQL/*.update.sql

since my database is in mysql. I run the mysql.update.sql included with the new build and that is when the following error occurs:
MySQL said:

#1062 - Duplicate entry '4-INBOX.msg-390' for key 2
and so I stop at this point. Luckily, I mad a copy of the whole roundcube directly before I tried the upgrade and I am able at this point to go back to my original build (Version 0.1-beta2) and it works fine. Fixes!! Please help. I really would like to get this upgraded to the newer build as we like the product.

Offline benedikt

  • Newbie
  • *
  • Posts: 2
Re: Error upgrading from Version 0.1-beta2 to Version 0.1-rc1
« Reply #5 on: October 03, 2007, 11:55:34 AM »
I did as explained in the INSTALL, as I replaced the whole folder where RC is installed. I used the mysql-initial and changed the configuration.

Its just strange that the old version works, the new doesnt.