Author Topic: Unable to install the carddav-plugin using composer  (Read 2046 times)

Offline thomas_g

  • Jr. Member
  • **
  • Posts: 19
Unable to install the carddav-plugin using composer
« on: September 17, 2015, 04:32:36 AM »
Hello,

I'm trying to install the carddav-plugin for roundcube via the composer following the instructions on https://plugins.roundcube.net/.
This is what I've done so far: I added "roundcube/carddav": "dev-master" to the require section in composer.json (and I did add the comma in the line above). Then I ran "php composer.phar install" in the shell. Doing this I get the following warning:
"Warning: The lock file is not up to date with the latest changes in composer.json. You may be getting outdated dependencies. Run update to update them."
So I ran "php composer.phar update", but then after the lines

"Updating nategood/httpful (dev-master b1f65de => 0.2.19)
    Checking out bd73f89d34d8f879c54ac46eb94b0f7be1d00820"

the following error occurs:

" [ErrorException]         
  Undefined index: 1.0.0.0"


Does anyone know what's going wrong?
I think this is not a general problem with the composer, because I could install the multiple_smtp_user-plugin (without any problems).

Further informations: I'm using rc 1.1.3 on a Ubuntu 14.04 server.

Best regards
Thomas

Offline TheMagican

  • Newbie
  • *
  • Posts: 1
Re: Unable to install the carddav-plugin using composer
« Reply #1 on: September 22, 2015, 01:04:35 PM »
Hi Thomas,

after updating my roundcube installation to v1.1.3 I got the same error but managed to find out, what the problem was:
http://bit-insomnia.de/en/2015/09/22/roundcube-error-undefined-index-1-0-0-0-rc-when-updating/

To cut it short: remove the "roundcube/plugin-installer": "XXXXXX" from the require part of your composer.json .


Andreas