Author Topic: 4 problems with Roundcube: lost attachments, max upload size, date and time  (Read 5875 times)

Offline ADolzhenkov

  • Newbie
  • *
  • Posts: 7
Hi !!

I'm running Roundcube 1.1.3 with Hmailserver on Windows Server 2012 R2, IIS 8, PHP 5.3.13 (Non-Thread-Safe), MySQL.

I have 4 problems:

1) All attachments are lost after send:

I have read the post http://www.roundcubeforum.net/index.php/topic,1756.msg7188.html
That doesn't help me (I have granted full access permissions for IUSR user and IIS-IUSRS group to all the folders involved [logs, temp, C:\Windows\Temp] )

NOTE that all attachments are delivered if I connect to Hmailserver from a mail client (Outlook).

2) I get the error "The uploaded file exceeds the maximum size of 2.0 MB."

In my php.ini I have set:

post_max_size = 30M
upload_max_filesize = 10M
memory_limit = 512M

I restarted the IIS server but the error persists.

3) Time zone:

I have (GMT +4:00) Europe/Moscow.

However, the actual local time is 1 hour behind.

4) Date and time:

Roundcube doesn't show the date and time of send or receipt in "Date" column.
- - - - - - - - - - - - - - - -

Can anyone help with these please??

 

Offline SKaero

  • Administrator
  • Hero Member
  • *****
  • Posts: 5,553
    • http://SKaero.com/
1. Sorry I can't with that, I don't use IIS.
2. Sorry I can't with that, I don't use IIS.
3. Is the hardware clock correct? Otherwise its most likely a PHP/IIS config problem.
4. You need to set the date.timezone in the php.ini

Offline ADolzhenkov

  • Newbie
  • *
  • Posts: 7
Hi SKaero, thank you for your even-faster-than-expected feedback!

What would be your answer to problems 1) and 2) if I ran Apache instead of IIS ?

Offline SKaero

  • Administrator
  • Hero Member
  • *****
  • Posts: 5,553
    • http://SKaero.com/
1. I would check if files are ever stored in the temp folder if they are the permissions are correct and that's not the problem. Also check the Roundcube error log to see if there is any information there.
2. Check and make sure the .htaccess isn't overwriting your changes. You can also create a test php file in the Roundcube directory with a phpinfo(); to check if the settings are actually being applied.

Offline ADolzhenkov

  • Newbie
  • *
  • Posts: 7
Thank you, I will try and feedback!

Offline ADolzhenkov

  • Newbie
  • *
  • Posts: 7
Hi SKaero!

I have all the permissions but I still have lost attachments and "File upload failed" error.

Here is some part of the log:

[16-Oct-2015 06:29:57 UTC] PHP Warning: Invalid argument supplied for foreach() in C:\inetpub\wwwroot\program\lib\Roundcube\rcube_spellcheck_enchant.php on line 44
[16-Oct-2015 06:30:50 UTC] PHP Warning: Invalid argument supplied for foreach() in C:\inetpub\wwwroot\program\lib\Roundcube\rcube_spellcheck_enchant.php on line 44
[16-Oct-2015 06:31:13 UTC] PHP Warning: finfo_open(): Failed to load magic database at 'C:\mime\magic\magic'. in C:\inetpub\wwwroot\program\lib\Roundcube\rcube_mime.php on line 711
[16-Oct-2015 06:31:13 UTC] PHP Warning: rcube_cache: max_packet_size (4192304) exceeded for key 7747692625620999a22e2d37c2d236ccddafa82747bac45978feb1. Tried to write 4680036 bytes in C:\inetpub\wwwroot\program\lib\Roundcube\rcube_cache.php on line 345
[16-Oct-2015 06:31:14 UTC] PHP Warning: rcube_cache: max_packet_size (4192304) exceeded for key 7747692625620999a22e2dd906d639936d653e5a64c5e65276531b. Tried to write 4680036 bytes in C:\inetpub\wwwroot\program\lib\Roundcube\rcube_cache.php on line 345
[16-Oct-2015 06:31:34 UTC] PHP Warning: finfo_open(): Failed to load magic database at 'C:\mime\magic\magic'. in C:\inetpub\wwwroot\program\lib\Roundcube\rcube_mime.php on line 711
[16-Oct-2015 06:31:34 UTC] PHP Warning: file_get_contents(): Filename cannot be empty in C:\inetpub\wwwroot\plugins\redundant_attachments\redundant_attachments.php on line 104
[16-Oct-2015 06:51:45 UTC] PHP Warning: Invalid argument supplied for foreach() in C:\inetpub\wwwroot\program\lib\Roundcube\rcube_spellcheck_enchant.php on line 44
[16-Oct-2015 08:11:24 UTC] PHP Warning: Invalid argument supplied for foreach() in C:\inetpub\wwwroot\program\lib\Roundcube\rcube_spellcheck_enchant.php on line 44
[17-Oct-2015 20:56:01 UTC] PHP Warning: Invalid argument supplied for foreach() in C:\inetpub\wwwroot\program\lib\Roundcube\rcube_spellcheck_enchant.php on line 44
[17-Oct-2015 20:56:45 UTC] PHP Warning: file_get_contents(): Filename cannot be empty in C:\inetpub\wwwroot\plugins\redundant_attachments\redundant_attachments.php on line 104
[17-Oct-2015 20:57:38 UTC] PHP Warning: Invalid argument supplied for foreach() in C:\inetpub\wwwroot\program\lib\Roundcube\rcube_spellcheck_enchant.php on line 44
[17-Oct-2015 20:58:10 UTC] PHP Warning: rcube_cache: max_packet_size (4192304) exceeded for key 17035285175622b641938c20e580f33c4b3401c061c3655afd15df6. Tried to write 4896756 bytes in C:\inetpub\wwwroot\program\lib\Roundcube\rcube_cache.php on line 345
[17-Oct-2015 20:58:11 UTC] PHP Warning: rcube_cache: max_packet_size (4192304) exceeded for key 17035285175622b641938c2575fbceea90b2aed2f7257bf2df80d9c. Tried to write 4896756 bytes in C:\inetpub\wwwroot\program\lib\Roundcube\rcube_cache.php on line 345
[17-Oct-2015 21:14:54 UTC] PHP Warning: Invalid argument supplied for foreach() in C:\inetpub\wwwroot\program\lib\Roundcube\rcube_spellcheck_enchant.php on line 44
[17-Oct-2015 21:33:20 UTC] PHP Warning: file_get_contents(): Filename cannot be empty in C:\inetpub\wwwroot\plugins\redundant_attachments\redundant_attachments.php on line 104
[18-Oct-2015 01:15:18 +0400]: <uillq9c5> DB Error: [1153] Got a packet bigger than 'max_allowed_packet' bytes (SQL Query: INSERT INTO `cache` (`created`, `expires`, `user_id`, `cache_key`, `data`) VALUES (now(), now() + INTERVAL 43200 SECOND, '1',
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

In defaults.inc.php file I have changed:

Maximum allowed packet

$config['db_max_allowed_packet'] = 104857600    (previous value - 4192304)

Maximum cached message size in kilobytes

$config['messages_cache_threshold'] = 51200    (previous value - 50)

But this didn't help.

What would you advise to do?



Offline alec

  • Hero Member
  • *****
  • Posts: 1,155
Is this multiserver installation? If not, just disable all *_attachments plugins.

Offline ADolzhenkov

  • Newbie
  • *
  • Posts: 7
Hi, thank for the reply!

I'm not sure what you mean by "multiserver installation", but I guess mine is not.

I will try and revert!

Offline ADolzhenkov

  • Newbie
  • *
  • Posts: 7
alec, that worked for me, many-many thanks, problem is solved!!)))

Offline ADolzhenkov

  • Newbie
  • *
  • Posts: 7
one more question please:

how set DST (day-light saving time) in the timezone ?

"Europe/Moscow DST" or otherwise ?