Author Topic: Gelöst: Enigma Plugin läuft nicht / open_basedir / Plesk Problem  (Read 4422 times)

Offline wikrie

  • Jr. Member
  • **
  • Posts: 12
Hi Com,

hat irgendjemand eine Idee was bei folgender Fehlermedung fehlt?

Application Error (600): Enigma plugin: GPG binary not found. If you are sure the GPG binary is installed, please specify the location of the GPG binary using the 'binary' driver option.

GPG ist natürlich installiert, auch in den Logs finde ich leider nichts, irgendjemand eine idee?

Umgebung: Standard RC 1.2 installation auf Ubuntu 14.04

Die komplette MEldung lautet dazu:

[24-May-2016 11:51:56 Europe/Berlin] PHP Warning:  is_executable(): open_basedir restriction in effect. File(/usr/bin/gpg) is not within the allowed path(s): (/var/www/vhosts/e.de/:/tmp/) in /var/www/vhosts/tld.de/mail.tld.de/vendor/pear-pear.php.net/Crypt_GPG/Crypt/GPG/Engine.php on line 1925

[24-May-2016 11:51:56 Europe/Berlin] PHP Warning:  is_executable(): open_basedir restriction in effect. File(/usr/local/bin/gpg) is not within the allowed path(s): (/var/www/vhosts/tld.de/:/tmp/) in /var/www/vhosts/tld.de/mail.tld.de/vendor/pear-pear.php.net/Crypt_GPG/Crypt/GPG/Engine.php on line 1925

[24-May-2016 11:51:56 +0200]: <4ath13rf> PHP Error: Enigma plugin: GPG binary not found. If you are sure the GPG binary is installed, please specify the location of the GPG binary using the 'binary' driver option. in /var/www/vhosts/tld.de/mail.tld.de/plugins/enigma/lib/enigma_engine.php on line 92 (POST /?_task=settings&_action=plugin.enigmakeys)


« Last Edit: May 25, 2016, 05:17:13 AM by wikrie »
mfg /br

WiKrIe

Offline wikrie

  • Jr. Member
  • **
  • Posts: 12
Re: Enigma Plugin läuft nicht
« Reply #1 on: May 24, 2016, 10:33:18 AM »
sieht so aus als würde Enigma erstmal nicht laufen sind 2 offen Threads im Github dazu

https://github.com/roundcube/roundcubemail/issues/5272

https://github.com/roundcube/roundcubemail/issues/5271

mal sehen wann es dazu Neuigkeiten gibt.
mfg /br

WiKrIe

Offline wikrie

  • Jr. Member
  • **
  • Posts: 12
Re: Enigma Plugin läuft nicht
« Reply #2 on: May 25, 2016, 05:14:47 AM »
jetzt läuft alles, es war ein Problem im Zusammenhang mit Plesk.
Plesk nutzt open_basedir option für PHP und dort musste man den Pfad zum gpg angeben.
Dort kann man nun das globale bin angeben /usr/bin/ oder wie ich zum Beispiel die locale Variante nachdem man gpg auch dort verfügbar gemacht hat /usr/local/bin/
Mir ist einfach wohler wenn nicht alle Bin's ausführbar sind und ein wenig Kontrolle darüber übrig bleibt.

hier also meine open_basedir Einstellung im Plesk für die entsprechende Subdomain in der ich RC laufen habe: {WEBSPACEROOT}{/}{:}{TMP}{/}:/usr/local/bin/

Danach kann man key Management öffnen und neue schlüssel erstellen oder importieren.


mfg
WiKrIe
mfg /br

WiKrIe