Author Topic: folders dont work  (Read 3340 times)

SuperATP

  • Guest
folders dont work
« on: December 05, 2007, 06:49:19 AM »
Have installed RC2 and the folders on the left hand side dont work.
when i log in i get my inbox and all messages are displayed, but if i click on any other folders the messages dont appear. its just blank.
then if i click back on inbox, again there are no messages displayed.
i have to log out and back in again to see the messages in my inbox!
this is driving me nuts! >:(
please help!!!!!
thanks
SuperATP

Offline wmiles

  • Newbie
  • *
  • Posts: 8
Re: folders dont work
« Reply #1 on: December 06, 2007, 01:00:23 PM »
Sounds like what i just had, found a fix though on the forum

in index.php for AJAX requests.
Comment out all the lines below

Code:
// check client X-header to verify request origin
if ($OUTPUT->ajax_call)
{
 if (empty($CONFIG['devel_mode']) && !rc_request_header('X-RoundCube-Referer'))
 {
  header('HTTP/1.1 404 Not Found');
  die("Invalid Request");
 }
}


Offline 12345p

  • Newbie
  • *
  • Posts: 4
Re: folders dont work
« Reply #2 on: December 06, 2007, 01:32:22 PM »
Thanks! Your fix worked perfectly for me.

On a related note, anyone having trouble with the "Folders" title header appearing inside the folder's list, overlapping at least one of the folder names?

Offline wmiles

  • Newbie
  • *
  • Posts: 8
Re: folders dont work
« Reply #3 on: December 07, 2007, 04:10:22 AM »
Yep i had that issue too, you hit refresh on IE and it seems to go away.

looking into it more though.

SuperATP

  • Guest
Re: folders dont work
« Reply #4 on: December 10, 2007, 07:00:58 AM »
thanks, i did find that before but realised that i wasn't commenting out correctly.
i was using single line // and not multiple line /* */

i finally have it working correctly, brill i can now use roundcube for clients as standard

woo! :D