Author Topic: trouble upgrading to latest version  (Read 3907 times)

Offline auricular

  • Newbie
  • *
  • Posts: 2
trouble upgrading to latest version
« on: January 21, 2017, 03:39:15 PM »
Hi,

having issues upgrading from 1.2.0 to 1.30.

log is:

Code: [Select]
ubuntu@ip-172-31-12-193:/opt/www$ ls
iredadmin        roundcubemail        roundcubemail-1.3-beta
iRedAdmin-0.6.3  roundcubemail-1.2.0  roundcubemail-1.3-beta-complete.tar.gz
ubuntu@ip-172-31-12-193:/opt/www$ cd roundcubemail-1.3-beta
ubuntu@ip-172-31-12-193:/opt/www/roundcubemail-1.3-beta$
ubuntu@ip-172-31-12-193:/opt/www/roundcubemail-1.3-beta$ bin/installto.sh /opt/www/roundcubemail-1.2.0
Upgrading from 1.2.0. Do you want to continue? (y/N)
y
Copying files to target location...PHP Warning:  copy(/opt/www/roundcubemail-1.2.0/.htaccess.orig): failed to open stream: Permission denied in /opt/www/roundcubemail-1.3-beta/bin/installto.sh on line 49
PHP Warning:  system() has been disabled for security reasons in /opt/www/roundcubemail-1.3-beta/bin/installto.sh on line 60
Error 500: Failed to execute command: rsync -aC --out-format "%n" --delete /opt/www/roundcubemail-1.3-beta/program/* /opt/www/roundcubemail-1.2.0/program/
ubuntu@ip-172-31-12-193:/opt/www/roundcubemail-1.3-beta$


Any ideas?

Offline JohnDoh

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 2,121
Re: trouble upgrading to latest version
« Reply #1 on: January 22, 2017, 02:35:06 AM »
Code: [Select]
Copying files to target location...PHP Warning:  copy(/opt/www/roundcubemail-1.2.0/.htaccess.orig): failed to open stream: Permission denied in /opt/www/roundcubemail-1.3-beta/bin/installto.sh on line 49
1) there is a permissions issue, the user you are running the script as does not have access to the 1.2.0 files

Code: [Select]
PHP Warning:  system() has been disabled for security reasons in /opt/www/roundcubemail-1.3-beta/bin/installto.sh on line 60
2) you need to enable system() in your php-cli config

PHP Warning:  system() has been disabled for security reasons in /opt/www/roundcubemail-1.3-beta/bin/installto.sh on line 60
Error 500: Failed to execute command: rsync -aC --out-format "%n" --delete /opt/www/roundcubemail-1.3-beta/program/* /opt/www/roundcubemail-1.2.0/program/
Roundcube Plugins: Contextmenu, SpamAssassin Prefs, and moreā€¦