Author Topic: Mail will send but takes a long time.  (Read 1589 times)

Offline iburnthings

  • Newbie
  • *
  • Posts: 9
Mail will send but takes a long time.
« on: March 01, 2017, 07:13:22 PM »
I see Sending... for a long time and either it will disappear and still be on the compose screen. Sometimes it will timeout.
It will send only when I click back and say I want to cancel the message but it still doesn't show in sent immediately.

Also the messages aren't being signed by openDKIM

This is a mailcow-0.14 install. Ubuntu. Nginx.
 I don't know how to get into the console but I can pull any logs or configs you need
Wondering if this line in my Nginx config is the issue

add_header Strict-Transport-Security max-age=15768000;

Thanks for your help :)

I sent a message and got it in the receipt inbox 5 mins later :/

Roundcube Webmail 1.2.1

Plugins that are installed (by mailcow)
acl 1.6 GPLv3+ 
archive 2.4 GPLv3+ 
attachment_reminder 1.1 GPLv3+ 
filesystem_attachments 1.0 GPLv3+ 
jqueryui 1.10.4 GPLv3+ 
managesieve 8.6 GPLv3+ 
new_user_dialog 2.1 GPLv3+ 
zipdownload 3.1 GPLv3+

Postfix config has deferred messages set to 300s so that might be it.

Before I reinstalled mailcow to try and fix the DKIM signing it was working faster. I wasnt' expecting to have all my messages still so maybe it's a permission issue on the mail storage folders in Ubuntu.
« Last Edit: March 01, 2017, 10:52:37 PM by iburnthings »

Offline JohnDoh

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 2,285
Re: Mail will send but takes a long time.
« Reply #1 on: March 02, 2017, 03:04:41 AM »
have you checked for any errors in your browser console. sometime the behaviour you describe of getting "stuck" on the sending screen is caused by having
Code: [Select]
add_header X-Frame-Options DENY; in your httpd config. Roundcube uses frames.

you could also try enabling smtp_debug in your roundcube config and then it will log the SMTP conversation so you can check that the server is responding in good time.
Roundcube Plugins: Contextmenu, SpamAssassin Prefs, and more…

Offline iburnthings

  • Newbie
  • *
  • Posts: 9
Re: Mail will send but takes a long time.
« Reply #2 on: March 07, 2017, 10:08:09 PM »
I checked the browser console and I'm not finding any errors. I'm using Nginx but I'll look for add_header X-Frame-Options option and set it to SAMEORIGIN if I find it.
---edit
Code: [Select]
add_header Strict-Transport-Security max-age=15768000;is the only thing I'm finding in my server mail server conf file.
« Last Edit: March 07, 2017, 10:11:27 PM by iburnthings »

Offline iburnthings

  • Newbie
  • *
  • Posts: 9
Re: Mail will send but takes a long time.
« Reply #3 on: March 08, 2017, 10:36:07 PM »
I added then disabled the add_header directive when it didn't change anything. I disabled all header directives, there are no warnings in my browser console. I enabled SMTP_Debug and just restarted. I just sent an email and don't know where to look for the log.

Offline JohnDoh

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 2,285
Re: Mail will send but takes a long time.
« Reply #4 on: March 09, 2017, 04:55:27 AM »
by default logs are in <rc root>/logs
Roundcube Plugins: Contextmenu, SpamAssassin Prefs, and more…

Offline iburnthings

  • Newbie
  • *
  • Posts: 9
Re: Mail will send but takes a long time.
« Reply #5 on: March 09, 2017, 06:16:54 PM »
Code: [Select]
[09-Mar-2017 04:35:42 +0100]: <ghs03fk2> Recv: 220 mail.MASKEDDOMAIN.com
[09-Mar-2017 04:35:42 +0100]: <ghs03fk2> Send: EHLO mail.MASKEDDOMAIN.com
[09-Mar-2017 04:35:42 +0100]: <ghs03fk2> Recv: 250-mail.MASKEDDOMAIN.com
[09-Mar-2017 04:35:42 +0100]: <ghs03fk2> Recv: 250-PIPELINING
[09-Mar-2017 04:35:42 +0100]: <ghs03fk2> Recv: 250-SIZE 104857600
[09-Mar-2017 04:35:42 +0100]: <ghs03fk2> Recv: 250-ETRN
[09-Mar-2017 04:35:42 +0100]: <ghs03fk2> Recv: 250-STARTTLS
[09-Mar-2017 04:35:42 +0100]: <ghs03fk2> Recv: 250-ENHANCEDSTATUSCODES
[09-Mar-2017 04:35:42 +0100]: <ghs03fk2> Recv: 250-8BITMIME
[09-Mar-2017 04:35:42 +0100]: <ghs03fk2> Recv: 250 DSN
[09-Mar-2017 04:35:42 +0100]: <ghs03fk2> Send: STARTTLS
[09-Mar-2017 04:35:42 +0100]: <ghs03fk2> Recv: 220 2.0.0 Ready to start TLS
[09-Mar-2017 04:35:42 +0100]: <ghs03fk2> Send: EHLO mail.MASKEDDOMAIN.com
[09-Mar-2017 04:35:42 +0100]: <ghs03fk2> Recv: 250-mail.MASKEDDOMAIN.com
[09-Mar-2017 04:35:42 +0100]: <ghs03fk2> Recv: 250-PIPELINING
[09-Mar-2017 04:35:42 +0100]: <ghs03fk2> Recv: 250-SIZE 104857600
[09-Mar-2017 04:35:42 +0100]: <ghs03fk2> Recv: 250-ETRN
[09-Mar-2017 04:35:42 +0100]: <ghs03fk2> Recv: 250-AUTH PLAIN LOGIN
[09-Mar-2017 04:35:42 +0100]: <ghs03fk2> Recv: 250-AUTH=PLAIN LOGIN
[09-Mar-2017 04:35:42 +0100]: <ghs03fk2> Recv: 250-ENHANCEDSTATUSCODES
[09-Mar-2017 04:35:42 +0100]: <ghs03fk2> Recv: 250-8BITMIME
[09-Mar-2017 04:35:42 +0100]: <ghs03fk2> Recv: 250 DSN
[09-Mar-2017 04:35:42 +0100]: <ghs03fk2> Send: AUTH LOGIN
[09-Mar-2017 04:35:42 +0100]: <ghs03fk2> Recv: 334 VXNlcm5hbWU6
[09-Mar-2017 04:35:42 +0100]: <ghs03fk2> Send: amVmZkBqbmppbmNhLmNvbQ==
[09-Mar-2017 04:35:42 +0100]: <ghs03fk2> Recv: 334 UGFzc3dvcmQ6
[09-Mar-2017 04:35:42 +0100]: <ghs03fk2> Send: ****** [12]
[09-Mar-2017 04:35:42 +0100]: <ghs03fk2> Recv: 235 2.7.0 Authentication successful
[09-Mar-2017 04:35:42 +0100]: <ghs03fk2> Send: MAIL FROM:<jeff@MASKEDDOMAIN.com>
[09-Mar-2017 04:35:42 +0100]: <ghs03fk2> Recv: 250 2.1.0 Ok
[09-Mar-2017 04:35:42 +0100]: <ghs03fk2> Send: RCPT TO:<MASKEDEMAIL@gmail.com>
[09-Mar-2017 04:35:42 +0100]: <ghs03fk2> Recv: 250 2.1.5 Ok
[09-Mar-2017 04:35:42 +0100]: <ghs03fk2> Send: DATA
[09-Mar-2017 04:35:42 +0100]: <ghs03fk2> Recv: 354 End data with <CR><LF>.<CR><LF>
[09-Mar-2017 04:35:42 +0100]: <ghs03fk2> Send: MIME-Version: 1.0
Content-Type: text/plain; charset=US-ASCII;
 format=flowed
Content-Transfer-Encoding: 7bit
Date: Wed, 08 Mar 2017 20:35:41 -0700
From: Jeffrey Becker <jeff@MASKEDDOMAIN.com>
To: MASKEDEMAIL@gmail.com
Subject: test24
Message-ID: <48cbcb68a60f48454a66cb805d7f8795@MASKEDDOMAIN.com>
X-Sender: jeff@MASKEDDOMAIN.com
User-Agent: Roundcube Webmail/1.2.1

test24
[09-Mar-2017 04:35:42 +0100]: <ghs03fk2> Send:
.
[09-Mar-2017 04:40:03 +0100]: <ghs03fk2> Recv: 250 2.0.0 Ok: queued as 6EB8937A075B
[09-Mar-2017 04:40:03 +0100]: <ghs03fk2> Send: QUIT
[09-Mar-2017 04:40:03 +0100]: <ghs03fk2> Recv: 221 2.0.0 Bye

Offline JohnDoh

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 2,285
Re: Mail will send but takes a long time.
« Reply #6 on: March 10, 2017, 02:09:08 AM »
that logs says it took 5 minutes for your smtp server to send the message. so it looks like your smtp server is the source of the delay in the roundcube ui (roundcube is simply waiting for it to respond).

perhaps someone in the community of your smtp server can help you track down why it is take so long.
Roundcube Plugins: Contextmenu, SpamAssassin Prefs, and more…

Offline iburnthings

  • Newbie
  • *
  • Posts: 9
Re: Mail will send but takes a long time.
« Reply #7 on: March 10, 2017, 04:25:17 PM »
okay, thanks. I'll dig through the configs and try with postfix on the Ubuntu forums. Feel free to close this issue, and thanks for the help.