Author Topic: RoundCube Upgrade to 1.24 - ERROR  (Read 1504 times)

Offline ritchie

  • Newbie
  • *
  • Posts: 6
RoundCube Upgrade to 1.24 - ERROR
« on: March 24, 2017, 08:55:28 AM »
roundcube upgrade to 1.24 - FAIL (updated performed from within Sofaculous)
SERVER RUNNING:

Apache Version    2.2.31
PHP Version    5.6.30
MySQL Version    5.5.51-38.2
Architecture    x86_64
Operating System    linux

ERROR log location:  /roundcube/error_log

LOG

[24-Mar-2017 07:55:25] PHP Parse error:  syntax error, unexpected ':' in /home/ACCOUNT/public_html/DOMAIN.com/roundcube/index.php on line 161
[24-Mar-2017 07:55:36] PHP Parse error:  syntax error, unexpected ':' in /home/ACCOUNT/public_html/DOMAIN.com/roundcube/index.php on line 161
[24-Mar-2017 07:57:04] PHP Parse error:  syntax error, unexpected ':' in /home/ACCOUNT/public_html/DOMAIN.com/roundcube/index.php on line 161
[24-Mar-2017 08:00:41] PHP Parse error:  syntax error, unexpected ':' in /home/ACCOUNT/public_html/DOMAIN.com/roundcube/index.php on line 161

note: while going to the main URL:  http://domain.com/roundcube , a blank page appears.
BACKUP was performed before upgrade.


index.php (original)
LINE: 161 

$error_message = !empty($auth['error']) && !is_numeric($auth['error']) ? $auth['error'] : ($error_labels[$error_code] ?: 'loginfailed');
« Last Edit: March 24, 2017, 09:03:13 AM by ritchie »

Offline rm13

  • Full Member
  • ***
  • Posts: 129
Re: RoundCube Upgrade to 1.24 - ERROR
« Reply #1 on: March 24, 2017, 09:37:04 AM »
Looks like a bug in Softaculous. No syntax error on that line that I see.

Offline ritchie

  • Newbie
  • *
  • Posts: 6
Re: RoundCube Upgrade to 1.24 - ERROR
« Reply #2 on: March 24, 2017, 09:48:11 AM »
Since I'm stuck here with no roundcube, what is my options?

Can I roll back to previous version? IF so how?  I did a backup.

Offline JohnDoh

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 2,285
Re: RoundCube Upgrade to 1.24 - ERROR
« Reply #3 on: March 25, 2017, 04:57:13 AM »
Are you sure that Roundcube is running under PHP 5.6? I ask because that error, about the ternary operator is something you can get with PHP <5.3
Roundcube Plugins: Contextmenu, SpamAssassin Prefs, and more…

Offline ritchie

  • Newbie
  • *
  • Posts: 6
Re: RoundCube Upgrade to 1.24 - ERROR
« Reply #4 on: March 25, 2017, 06:24:53 AM »


I have one domain on a shared host that I have to run PHP 5.2.17

Their is a particular script that will not run on any PHP later than this version.

I instructed the hosting provider to only run this version on this domain because of that particular script has not yet been
updated to run on the latest version of PHP and MYSql.  (PHP Motion).

So I probably need to upgrade PHP for the domain that I'm running roundcube in so that it will function.

What is the latest version of PHP that "roundcube" will run under, I guess is my last question?

Offline JohnDoh

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 2,285
Re: RoundCube Upgrade to 1.24 - ERROR
« Reply #5 on: March 25, 2017, 06:37:43 AM »
the current stable version of roundcube has a php minimum version requirement of 5.4

maximum version of php is harder to answer. I think support for php7 was added in 1.2
Roundcube Plugins: Contextmenu, SpamAssassin Prefs, and more…

Offline ritchie

  • Newbie
  • *
  • Posts: 6
Re: RoundCube Upgrade to 1.24 - ERROR
« Reply #6 on: March 25, 2017, 08:48:02 AM »
Got it to work.  The latest version of Round Cube which as of this date is:  1.2.4, does not work on PHP version 5.2.X
I changed the PHP server to version PHP 5.4 and Boom! Pow! Bang! ---------- IT works!!! :)
 8) 8) 8) 8) 8) 8) 8) 8)