Author Topic: Solution to Blank Page  (Read 2963 times)

Offline jfreake

  • Newbie
  • *
  • Posts: 5
Solution to Blank Page
« on: August 01, 2006, 07:28:11 AM »
I just finished downloading and installing roundcubemail-0.1beta.tar.gz.

I setup MySQL and made the configuration changes but when I attempted to bring up the first page, all I got was a blank page.
Here is what worked for me....

I edited the .htaccess file in the main dir and changed display_errors to "On":
Code: [Select]
php_flag   display_errors On
This will allow me to see the error that is taking place in the background.
The error that was displayed was:
Code: [Select]
Fatal error: Failed opening required 'include/rcube_shared.inc'
(include_path='/var/www/mailserver/html/rcube/PATH_SEPARATOR/var/www/mailserver/html/rcube/programPATH_SEPARATOR/var/www/mailserver/html/rcube/program/libPATH_SEPARATOR.:/usr/share/pear')
in /var/www/mailserver/html/rcube/index.php on line 77

The path separator is supposed to be a ":" .... not "PATH_SEPARATOR"
I guess for some reason, on my install of Red Hat 9 the PATH_SEPARATOR is not filled in correctly so I added a line to index.php in the main dir.

after the line define('RCMAIL_VERSION', '0.1-20060220'); I added:
Code: [Select]
define('PATH_SEPARATOR', ':');
This seemed to work great for me.
Hope this helps and don't forget to turn display_errors back to "Off" in the .htaccess :)

Jason Freake

Offline flosoft

  • Sr. Member
  • ****
  • Posts: 349
    • http://flosoft.biz
Re: Solution to Blank Page
« Reply #1 on: August 01, 2006, 07:52:52 AM »
thx :D