Author Topic: select all doesnt work  (Read 3780 times)

Offline andipreza

  • Newbie
  • *
  • Posts: 1
select all doesnt work
« on: April 17, 2018, 06:10:42 PM »
Hi,

on my roundcube at my cpanel whm server,
when i make select all , all mails selected but if i make mark as read, or delete , or mark as undread ..
give me an error "
Server Error: UID STORE: Error in IMAP command UID STORE: Invalid uidset (0.001 + 0.000 secs)."

But when i give the command select the current page everything its OK.

Can you help me why?

Thank you,


Offline keducation

  • Newbie
  • *
  • Posts: 1
Re: select all doesnt work
« Reply #1 on: April 21, 2018, 04:24:58 AM »
I have the same problem.

Offline JohnDoh

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 2,248
Re: select all doesnt work
« Reply #2 on: April 21, 2018, 04:57:21 AM »
what version of roundcube are you running? how many messages are you selecting exactly? and finally do you have the same problem with the "mark all as read" function (from the actions menu at the bottom of the folder list on the mail screen)?
Roundcube Plugins: Contextmenu, SpamAssassin Prefs, and moreā€¦

Offline alec

  • Hero Member
  • *****
  • Posts: 1,145
Re: select all doesnt work
« Reply #3 on: April 21, 2018, 05:23:36 AM »
It looks like it might be a bug in 1.2.8 and 1.1.11.

https://github.com/roundcube/roundcubemail/commit/dc9c9c36a8c7fbb821e55cd5c3cd13f36ab15ef0 has been backported partially.

Offline alec

  • Hero Member
  • *****
  • Posts: 1,145
Re: select all doesnt work
« Reply #4 on: April 21, 2018, 05:35:37 AM »
I fixed this in git and notified our release manager. Fix: https://github.com/roundcube/roundcubemail/commit/0c9074f286c5f51ac9aeeafa2f0758dae71c4620

Feel free to notify cPanel developers.