Author Topic: Login ok, but RC still not working  (Read 81 times)

Offline labeske

  • Newbie
  • *
  • Posts: 2
Login ok, but RC still not working
« on: May 16, 2018, 05:28:11 AM »
Hello everyone !
I finally decide to post here because I didn't find any solution on the web that worked for me :/

I explain my situation :
I installed RC 1.2.9 on my Raspbian 9 home server, who was already running Nginx/Dovecot/Postfix/MariaDB.
Everything in the install worked like a charm, no errors and the final test of IMAP & SMTP worked fine.
I use Evolution to connect on that mail server so I did receive the "Test message from roundcube".
Login to RC is ok, but I can't send or receive any mails (seems to be running into void with the loading logo visible) and all of my folders (who are well detected) are empty !

I tried several differents configurations but I'm completely stuck right now. Maybe a fresh look over the situation will lead me to fixing this issue :)
Stranges things are there is no errors nowhere (in the log directory of RC, or in /var/log/mail.* etc...).
And when I create a new directory in Evolution for example it appears instantly in RC, but no matter what I do it still being empty.
Note that RC also get stuck (at least for a while) when I try to access preferences settings, and never shows the menu I asked for.

I am a bit lost right now so don't hesitate to tell me any ideas or leads !

Have a nice day :D

ps : I can post config output if needed

------------------------------------------------
RC 1.2.9 --> Nginx/Dovecot/Postfix/MariaDB
« Last Edit: May 16, 2018, 08:41:10 AM by labeske »

Offline alec

  • Hero Member
  • *****
  • Posts: 1,083
Re: Login ok, but RC still not working
« Reply #1 on: May 16, 2018, 07:11:20 AM »
Looks like X-Frame-Options related issue. Configure http server to allow frames.

Offline labeske

  • Newbie
  • *
  • Posts: 2
Re: Login ok, but RC still not working
« Reply #2 on: May 16, 2018, 08:36:26 AM »
Looks like you are the man :)

My nginx.conf was already set with frames allowed
Code: [Select]
add_header X-Frame-Options SAMEORIGIN;
But I saw just few lines after that my Content-Security-Policy was misconfigured, I commented the line and everything just appear  :D
I know it looks like a noob story but please don't laugh at me it was really a pain in my a** !

Thank you so much alec.