Author Topic: Folders suddenly disappeared  (Read 2588 times)

Offline christerlindh

  • Newbie
  • *
  • Posts: 4
Folders suddenly disappeared
« on: August 16, 2018, 04:30:08 PM »
I run Roundcube Webmail 1.2.3 and connect to Dovecot 2.2.9 running on Ubuntu 14.04.5 LTS.

Suddenly a new folder appeared (with the name being a concatenation of the names of the preceding folder and its parent folder). I deleted the new folder through Roundcube and then a lot of my folders disappeared, and the remaining top folders are greyed (but not the subfolders).

Checking my Maildir folder on the Linux server I concluded that the folders are still there. Then I connected with the Mail app in my iPhone and everything is still there and looks as it should. Which leads me to the conclusion that it must be a Roundcube problem.

Anyone who can guess what has happened and what to do to fix it?

/Christer

Offline JohnDoh

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 2,260
Re: Folders suddenly disappeared
« Reply #1 on: August 18, 2018, 03:25:34 AM »
What have you changed in your IMAP server or Roundcube setup/config recently? Perhaps something to do with the namespaces or the root folder? You could try enabling imap_debug in Roundcube, the log will show you the folder structure by your IMAP server and info about namespaces.
Roundcube Plugins: Contextmenu, SpamAssassin Prefs, and more…

Offline christerlindh

  • Newbie
  • *
  • Posts: 4
Re: Folders suddenly disappeared
« Reply #2 on: August 18, 2018, 06:25:36 AM »
I haven't changed anything for ages, neither in Roundcube, Dovecot or on my Linux server. It has been running perfectly and then suddenly this just happened.

OK, I try to find out how to enable imap_debug and come back with the results.

Offline christerlindh

  • Newbie
  • *
  • Posts: 4
Re: Folders suddenly disappeared
« Reply #3 on: August 18, 2018, 10:46:14 AM »
I turned on imap_debug and reloaded Roundcube in the web browser. I get messages like:

[18-Aug-2018 13:12:10 +0200]: <ih7gqk0v> [2EC9] S: * LIST (\Subscribed) "." "Scouting.Jamboree 2011"

and also

[18-Aug-2018 13:12:12 +0200]: <ih7gqk0v> [8E33] C: A0122 STATUS "Scouting.Jamboree 2011" (MESSAGES UNSEEN)
[18-Aug-2018 13:12:12 +0200]: <ih7gqk0v> [8E33] S: * STATUS "Scouting.Jamboree 2011" (MESSAGES 706 UNSEEN 0)
[18-Aug-2018 13:12:12 +0200]: <ih7gqk0v> [8E33] S: A0122 OK Status completed.

for all the folders that I see in Roundcube, but not for the ones I don't see, and not for the ones that are greyed (except as part of the path for the subfolders that are not greyed). The missing and greyed folders are not mentioned in the log file at all.

I don't find any error message neither in "imap" or "errors" log files.

Offline JohnDoh

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 2,260
Re: Folders suddenly disappeared
« Reply #4 on: August 18, 2018, 11:33:21 AM »
Depending on where in Roundcube you where when you reloaded the screen then only subscribed folders might have been requested from the IMAP server. Please could you go to Settings > Folders in Roundcube, there it will list all the available folders reported by your IMAP server (and the response will also be in the debug log) along with which ones you are subscribed to. From your description of the grey folders it sounds like you are subscribed to some child folders but not their parent. If there are folders missing from that list it could be your mailbox is corrupt or something like that so it might be worth also checking your dovecot logs for any errors.
Roundcube Plugins: Contextmenu, SpamAssassin Prefs, and more…

Offline christerlindh

  • Newbie
  • *
  • Posts: 4
Re: Folders suddenly disappeared
« Reply #5 on: August 19, 2018, 11:08:35 AM »
Ah, it was that simple! You were correct - some of the folders had been unsubscribed in the settings window. I don't know how it happened, but it must have be when that new folder suddenly appeared and I removed it... Now it seems to be working as it should again!

Many, many thanks for taking your time to help me.