Author Topic: customer just started getting this in RC 1.3!  (Read 1383 times)

Offline theeldestgeek

  • Newbie
  • *
  • Posts: 7
customer just started getting this in RC 1.3!
« on: October 05, 2018, 05:43:10 PM »
when she does a search (with only the first 4 options ticked) - for say WITTY gets and error:

Server Error: UID SEARCH: Error in IMAP command UID SEARCH: Unknown argument WITTY

and log has:
snip--
Oct  5 17:16:26 ns9 roundcube: <l1p0ou93> [1241] S: A0003 OK [READ-WRITE] Select completed (0.029 secs).
Oct  5 17:16:26 ns9 roundcube: <l1p0ou93> [1241] C: A0004 UID SORT (DATE) US-ASCII ALL OR OR OR OR OR HEADER * witty HEADER SENT witty HEADER DRAFTS witty HEADER INBOX witty HEADER JUNK witty HEADER INBOX.PR.SENT OBJECTS witty
Oct  5 17:16:26 ns9 roundcube: <l1p0ou93> [1241] S: A0004 BAD Error in IMAP command UID SORT: Unknown argument WITTY
Oct  5 17:16:26 ns9 roundcube: <l1p0ou93> [1241] C: A0005 UID SEARCH RETURN (ALL) OR OR OR OR OR HEADER * witty HEADER SENT witty HEADER DRAFTS witty HEADER INBOX witty HEADER JUNK witty HEADER INBOX.PR.SENT OBJECTS witty
Oct  5 17:16:26 ns9 roundcube: <l1p0ou93> [1241] S: A0005 BAD Error in IMAP command UID SEARCH: Unknown argument WITTY
Oct  5 17:16:26 ns9 roundcube: <l1p0ou93> [1241] C: A0006 GETQUOTAROOT INBOX
Oct  5 17:16:26 ns9 roundcube: <l1p0ou93> [1241] S: A0006 OK No quota.
snip--


any ideas what is going on?
thanks

Offline alec

  • Hero Member
  • *****
  • Posts: 1,144
Re: customer just started getting this in RC 1.3!
« Reply #1 on: October 06, 2018, 01:41:42 AM »
Strange. What plugins are enabled? Try with disabled all plugins.

Offline theeldestgeek

  • Newbie
  • *
  • Posts: 7
Re: customer just started getting this in RC 1.3!
« Reply #2 on: October 07, 2018, 09:35:26 AM »
no plugins at all.  and by search I just mean she puts witty in the search box at top right!

nothing fancy. and only appears to be one user, one mailbox.

but how to fix?????

Offline theeldestgeek

  • Newbie
  • *
  • Posts: 7
Re: customer just started getting this in RC 1.3!
« Reply #3 on: October 07, 2018, 10:05:48 AM »
additional information - from phpmysqladmin roundcube database the user preferences are:

for malfunctioning box:
a:14:{s:11:"search_mods";a:9:{s:1:"*";a:2:{s:7:"subject";i:1;s:4:"from";i:1;}s:4:"Sent";a:2:{s:7:"subject";i:1;s:2:"to";i:1;}s:6:"Drafts";a:2:{s:7:"subject";i:1;s:2:"to";i:1;}s:5:"INBOX";a:9:{s:1:"*";i:1;s:4:"Sent";i:1;s:6:"Drafts";i:1;s:5:"INBOX";i:1;s:4:"Junk";i:1;s:21:"INBOX.PR.Sent objects";i:1;s:7:"subject";i:1;s:4:"from";i:1;s:2:"to";i:1;}s:4:"Junk";a:2:{s:7:"subject";i:1;s:4:"from";i:1;}s:21:"INBOX.PR.Sent objects";a:2:{s:7:"subject";i:1;s:4:"from";i:1;}s:5:"Trash";a:2:{s:7:"subject";i:1;s:4:"from";i:1;}s:12:"INBOX.Drafts";a:2:{s:7:"subject";i:1;s:4:"from";i:1;}s:11:"INBOX.Witti";a:2:{s:7:"subject";i:1;s:4:"from";i:1;}}s:14:"compose_extwin";i:0;s:11:"mdn_default";b:0;s:11:"dsn_default";b:0;s:22:"spellcheck_before_send";b:1;s:9:"sig_below";b:1;s:25:"compose_save_localstorage";i:1;s:16:"message_sort_col";s:4:"date";s:18:"message_sort_order";s:4:"DESC";s:6:"layout";s:4:"list";s:13:"mail_pagesize";i:200;s:17:"message_threading";a:2:{s:10:"INBOX.SPAM";b:0;s:9:"INBOX.HAM";b:0;}s:9:"list_cols";a:8:{i:0;s:6:"fromto";i:1;s:7:"threads";i:2;s:7:"subject";i:3;s:6:"status";i:4;s:4:"date";i:5;s:4:"size";i:6;s:4:"flag";i:7;s:10:"attachment";}s:11:"client_hash";s:16:"r0J39rgzCkyyjB7N";}


from a good box: (no errors)

a:14:{s:11:"search_mods";a:14:{s:1:"*";a:2:{s:7:"subject";i:1;s:4:"from";i:1;}s:4:"Sent";a:1:{s:4:"text";i:1;}s:6:"Drafts";a:2:{s:7:"subject";i:1;s:2:"to";i:1;}s:5:"INBOX";a:5:{s:7:"subject";i:1;s:4:"from";i:1;s:2:"to";i:1;s:2:"cc";i:1;s:3:"bcc";i:1;}s:9:"INBOX.HAM";a:2:{s:7:"subject";i:1;s:4:"from";i:1;}s:5:"Trash";a:2:{s:7:"subject";i:1;s:4:"from";i:1;}s:15:"Archive.OLDMAIL";a:2:{s:7:"subject";i:1;s:4:"from";i:1;}s:4:"Junk";a:2:{s:7:"subject";i:1;s:4:"from";i:1;}s:17:"Archive.WORDPRESS";a:2:{s:7:"subject";i:1;s:4:"from";i:1;}s:17:"Archive.THUMBTACK";a:2:{s:7:"subject";i:1;s:4:"from";i:1;}s:14:"Archive.Paypal";a:2:{s:7:"subject";i:1;s:4:"from";i:1;}s:16:"Archive.NEXTDOOR";a:2:{s:7:"subject";i:1;s:4:"from";i:1;}s:15:"Archive.GROUPON";a:2:{s:7:"subject";i:1;s:4:"from";i:1;}s:12:"Archive.EBAY";a:2:{s:7:"subject";i:1;s:4:"from";i:1;}}s:16:"message_sort_col";s:4:"date";s:18:"message_sort_order";s:4:"DESC";s:17:"message_threading";a:11:{s:10:"INBOX.SPAM";b:0;s:9:"INBOX.HAM";b:0;s:15:"Archive.GROUPON";b:0;s:17:"Archive.THUMBTACK";b:0;s:14:"Archive.Paypal";b:0;s:17:"Archive.WORDPRESS";b:0;s:15:"Archive.OLDMAIL";b:0;s:16:"Archive.NEXTDOOR";b:0;s:12:"Archive.EBAY";b:0;s:15:"Archive.YOUTUBE";b:0;s:14:"Archive.SQUARE";b:0;}s:6:"layout";s:7:"desktop";s:14:"message_extwin";i:0;s:11:"show_images";i:1;s:14:"compose_extwin";i:0;s:11:"mdn_default";b:0;s:11:"dsn_default";b:0;s:10:"reply_mode";i:1;s:25:"compose_save_localstorage";i:1;s:23:"addressbook_search_mods";a:5:{s:4:"name";i:1;s:9:"firstname";i:1;s:7:"surname";i:1;s:5:"email";i:1;s:1:"*";i:1;}s:11:"client_hash";s:32:"efa7abb7ade717387706470f25acfe74";}


does this help?  I read someone else haveing problem and the user prefs search_mods was supposedly the problem!  any enlightenment?

Offline theeldestgeek

  • Newbie
  • *
  • Posts: 7
Re: customer just started getting this in RC 1.3!
« Reply #4 on: October 07, 2018, 10:07:51 AM »
the first box above is from the user that cannot search on inbox without error - the next block is from my own user preferences, and I have no problems doing searches!

Offline JohnDoh

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 2,226
Re: customer just started getting this in RC 1.3!
« Reply #5 on: October 07, 2018, 01:10:32 PM »
the prefs from the broken user do appear to contain an error. try changing them to this:

Code: [Select]
a:14:{s:11:"search_mods";a:8:{s:1:"*";a:2:{s:7:"subject";i:1;s:4:"from";i:1;}s:4:"Sent";a:2:{s:7:"subject";i:1;s:2:"to";i:1;}s:6:"Drafts";a:2:{s:7:"subject";i:1;s:2:"to";i:1;}s:4:"Junk";a:2:{s:7:"subject";i:1;s:4:"from";i:1;}s:21:"INBOX.PR.Sent objects";a:2:{s:7:"subject";i:1;s:4:"from";i:1;}s:5:"Trash";a:2:{s:7:"subject";i:1;s:4:"from";i:1;}s:12:"INBOX.Drafts";a:2:{s:7:"subject";i:1;s:4:"from";i:1;}s:11:"INBOX.Witti";a:2:{s:7:"subject";i:1;s:4:"from";i:1;}}s:14:"compose_extwin";i:0;s:11:"mdn_default";b:0;s:11:"dsn_default";b:0;s:22:"spellcheck_before_send";b:1;s:9:"sig_below";b:1;s:25:"compose_save_localstorage";i:1;s:16:"message_sort_col";s:4:"date";s:18:"message_sort_order";s:4:"DESC";s:6:"layout";s:4:"list";s:13:"mail_pagesize";i:200;s:17:"message_threading";a:2:{s:10:"INBOX.SPAM";b:0;s:9:"INBOX.HAM";b:0;}s:9:"list_cols";a:8:{i:0;s:6:"fromto";i:1;s:7:"threads";i:2;s:7:"subject";i:3;s:6:"status";i:4;s:4:"date";i:5;s:4:"size";i:6;s:4:"flag";i:7;s:10:"attachment";}s:11:"client_hash";s:16:"r0J39rgzCkyyjB7N";}
Roundcube Plugins: Contextmenu, SpamAssassin Prefs, and more…

Offline theeldestgeek

  • Newbie
  • *
  • Posts: 7
Re: customer just started getting this in RC 1.3!
« Reply #6 on: October 07, 2018, 05:54:46 PM »
GREAT - fixed the error - now please explain??? what was error and what caused it??
thanks

Offline JohnDoh

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 2,226
Re: customer just started getting this in RC 1.3!
« Reply #7 on: October 08, 2018, 11:38:19 AM »
the search_mods param contained some bad information, specifically:
Code: [Select]
s:5:"INBOX";a:9:{s:1:"*";i:1;s:4:"Sent";i:1;s:6:"Drafts";i:1;s:5:"INBOX";i:1;s:4:"Junk";i:1;s:21:"INBOX.PR.Sent objects";i:1;s:7:"subject";i:1;s:4:"from";i:1;s:2:"to";i:1;}it should only contain search fields, not folder names.

I have no idea who it could have got in there.
Roundcube Plugins: Contextmenu, SpamAssassin Prefs, and more…