Author Topic: Slow performance on localhost  (Read 1064 times)

Offline ollea

  • Newbie
  • *
  • Posts: 2
Slow performance on localhost
« on: November 15, 2018, 03:04:19 AM »
Hello,

I moved Roundcube from one server to another and since this move every request are very slow, 3-4 seconds for login, loading a message, changing folder, ...

So, I enabled IMAP debug mode but I think this delay is not coming from IMAP as it takes 3-4 seconds before something is logged on the server.

I noticed that on the previous server the users were marked as coming from "localhost" in the "mail_host" column of "users" table but since the move the "mail_host" column is set to the complete hostname of the new server.
Here is the host defined in the config: $config['default_host'] = 'localhost'
So I guess the delay is coming from a DNS issue.

Any help will be very welcome!

Offline JohnDoh

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 2,187
Re: Slow performance on localhost
« Reply #1 on: November 15, 2018, 05:28:36 AM »
the contents of the mail_host field in the database generally comes from the default_host config option so may be you have edited the wrong config file or may be you have a plugin which is altering it?

when you say you moved Roundcube do you mean that you moved your entire mail stack or only roundcube (coz if you moved only roundcube then using localhost will not work)
Roundcube Plugins: Contextmenu, SpamAssassin Prefs, and moreā€¦

Offline ollea

  • Newbie
  • *
  • Posts: 2
Re: Slow performance on localhost
« Reply #2 on: November 15, 2018, 06:01:44 AM »
Right, it was coming from a third party plugin...

Thank you for your prompt help!
« Last Edit: November 15, 2018, 06:12:35 AM by ollea »