Author Topic: CentOS update killed roundcube? Please help.  (Read 2403 times)

Offline sls

  • Newbie
  • *
  • Posts: 2
CentOS update killed roundcube? Please help.
« on: December 30, 2018, 07:00:23 PM »
Good day all.
All I did was a "yum update" command and updated. I got a message "96 packages excluded due to repository priority protections".

Roundcube was working perfectly before I did this.
Imap still functions perfectly, but webmail url now has a strange plain text login which does nothing but give an error when you try to login.

"yum update -d3" command shows 96 packages that gives the excluded error. Among them is php and a roundcube package. I can get the complete list if needed.

Suggestions are welcomed.
« Last Edit: December 31, 2018, 08:08:36 AM by sls »

Offline SKaero

  • Administrator
  • Hero Member
  • *****
  • Posts: 5,518
    • http://SKaero.com/
Re: CentOS update killed roundcube? Please help.
« Reply #1 on: December 31, 2018, 03:54:55 PM »
I'm guessing the Roundcube package wasn't updated. I'd recommend installing Roundcube directly.

Offline sls

  • Newbie
  • *
  • Posts: 2
Re: CentOS update killed roundcube? Please help.
« Reply #2 on: January 01, 2019, 01:25:09 PM »
After roundcube login I get:

"The requested URL /roundcubemail/eddfb1476ffd32/ was not found on this server."

It sounds like this issue:
https://lists.kolab.org/pipermail/users/2014-September/017832.html

So is it a https/authentication issue??

I think I have 1.4.x installed. Is there a way to check for sure?

Can I re-install ontop of my existing roundcube and settings be intact?



Offline JohnDoh

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 2,260
Re: CentOS update killed roundcube? Please help.
« Reply #3 on: January 02, 2019, 03:43:07 PM »
Have you tried the things mentioned on the mailing list that you linked to? Have you checked if the rewrite rules are in place in your https site config file? There are some comments in defaults.inc.pup about the rewrite rules required. I guess you have enabled secure urls deliberately but if not may be just set use_secure_urls to false in your Roundcube config file?

Quote
I think I have 1.4.x installed

There is no stable version of 1.4 only the beta right now. The use_secure_urls option was added in version 1.1.
Roundcube Plugins: Contextmenu, SpamAssassin Prefs, and moreā€¦