Author Topic: Solved (kinda..) : Caldavzap not working anymore....or does it ?  (Read 1533 times)

Offline phloks

  • Newbie
  • *
  • Posts: 4
Hi,

I'm using caldavzap to be able to view my calendars.
There's one strange thing, though....
When I go to my calendars using Firefox (latest) at home, all works well.
However, at the office, using the same version of Firefox, when I go to my calendars, I get a page saying 'Loading resources (1 of 1)' , and it stays there..

In the webconsole I see this :

Code: [Select]
Info: loadConfig main_rc.min.js:1:25768
XML-parsefout: onjuist gevormd
Locatie:
Regelnummer 1, kolom 118:
Error: [netFindResource: 'PROPFIND https://hans@www.hanslammerts.nl/davical/caldav.php/hans/']: code: '503' status: 'error' webdav_protocol.min.js:2:4066
Error: [netFindResource]: 'Unable to load resources' webdav_protocol.min.js:2:1699
XML-parsefout: niet-overeenkomende tag. Verwacht: </meta>.
Locatie: https://www.hanslammerts.nl/webmail/plugins/caldavzap/caldavzap_0.13.2/roundcube.html
Regelnummer 26, kolom 3: roundcube.html:26:3

It's in Dutch, but translates more or less like this :
Code: [Select]
Info: loadConfig main_rc.min.js:1:25768
XML-parse-error: Not well-formed Location:
Linenumber 1, column 118:
Error: [netFindResource: 'PROPFIND https://hans@www.hanslammerts.nl/davical/caldav.php/hans/']: code: '503' status: 'error' webdav_protocol.min.js:2:4066
Error: [netFindResource]: 'Unable to load resources' webdav_protocol.min.js:2:1699
XML-parse-error: not matching tag. Expected: </meta>.
Location: https://www.hanslammerts.nl/webmail/plugins/caldavzap/caldavzap_0.13.2/roundcube.html
Linenumber 26, column 3: roundcube.html:26:3

I looked in the firewall logging, but nothing appears to be blocked when going to the calendars page.

Any suggestions what could be the issue here, please ?
« Last Edit: February 18, 2019, 04:20:20 AM by phloks »

Offline SKaero

  • Administrator
  • Hero Member
  • *****
  • Posts: 5,489
    • http://SKaero.com/
Re: Caldavzap not working anymore....or does it ?
« Reply #1 on: January 31, 2019, 01:42:11 PM »
503 is a server side error so I'd recommend looking at the error log on the server to find more information.

Offline phloks

  • Newbie
  • *
  • Posts: 4
Re: Caldavzap not working anymore....or does it ?
« Reply #2 on: February 01, 2019, 05:05:21 AM »
Well, that's just it....
There seems to be no relevant logging to this problem.

When I look into the apache acces-log, I only see 200's and an occasional 207, but no 503.
Nothing is written to apache's error-log.

There's nothing in /opt/roundcube/logs/*.log either....

??

Offline phloks

  • Newbie
  • *
  • Posts: 4
Re: Caldavzap not working anymore....or does it ?
« Reply #3 on: February 18, 2019, 04:19:24 AM »
Replying to my own question:

It turns out that our company firewall actively blocks WebDAV.....
Since WebDAV is considered dangerous (highest classification for potential risk) this will not be allowed....

Bummert... :'( :'(