Author Topic: Favicon doesn't show  (Read 687 times)

Offline DutchMoose

  • Newbie
  • *
  • Posts: 3
Favicon doesn't show
« on: February 07, 2019, 07:50:09 AM »
Hello all,

I'm a newbie so please bare with me. And if this question/topic is in the wrong location, my sincere apologies.

So the issue I got is this: when I go to the url of my webmail, the favicon doesn't show up. (See '20190207 - Afbeelding 001.png')
Even after clearing all browser cash and reloading the page.....

When I look in Firefox - DOM Inspector, and look inside the title element of the page, I see a link to the favicon in an unexpected location: './skin/favicon.ico'

When I login to the webmail, and do the same, I see the same unexpected location: './skin/favicon.ico'

When I logout of the webmail, and again go to the DOM Inspector, I see a different, but still unexpected location: 'skins/larry/favicon.ico'

I would expect to see './skin/larry/images/favicon.ico' as that is the location of the favicon for the Larry skin.

Any thoughts on this? Where can I check/change this?

Thanks in advance.

Offline JohnDoh

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 2,260
Re: Favicon doesn't show
« Reply #1 on: February 07, 2019, 08:40:23 AM »
what version of roundcube are you running? have you customised the larry skin or are you running any plugins?
Roundcube Plugins: Contextmenu, SpamAssassin Prefs, and more…

Offline DutchMoose

  • Newbie
  • *
  • Posts: 3
Re: Favicon doesn't show
« Reply #2 on: February 08, 2019, 09:33:51 AM »
I'm running the latest version of Roundcube [v1.3.8]. The Larry skin is as shipped, so no customization.

I only added $config['product_name'] = 'Moosecraft Webmail, powered by Roundcube'; to './config/config.inc.php'.

Yes, I'm running several plugins:
'archive', 'emoticons', 'enigma', 'filesystem_attachments', 'hide_blockquote', 'identicon', 'identity_select', 'markasjunk', 'newmail_notifier', 'customizr', 'filters', 'carddav', 'virtual_user_mapping', 'rcfilters', 'image_paster', 'html5_notifier', 'message_highlight', 'calendar_notifier', 'contextmenu', 'contextmenu_folder', 'twofactor_gauthenticator'.

My initial thoughts were that it could be an issue with the 'customizr' plugin. Disabling the plugin didn't result in solving the issue.

Offline JohnDoh

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 2,260
Re: Favicon doesn't show
« Reply #3 on: February 08, 2019, 01:34:47 PM »
My first guess would also have been the customizr plugin. Are you sure it was disabled properly? One way to double check is to have a look at the About screen after you login. I'm not familiar with all the plugins you have listed though so my advice would be to disable them all. If the favicon goes back to normal then enable them one by one until you find the culprit.
Roundcube Plugins: Contextmenu, SpamAssassin Prefs, and more…

Offline DutchMoose

  • Newbie
  • *
  • Posts: 3
Re: Favicon doesn't show
« Reply #4 on: February 11, 2019, 04:56:13 AM »
I've updated all the plugins and disabled the 'customizr' plugin. Now it's working like it should be.
The 'customizr' plugin is not working like it should be, so I wil just copy the 'larry' skin and make a custom version out of it.

Thanks for the help on this one.