Author Topic: Solved : Noob Help. Installer 404 error  (Read 324 times)

Offline chewiesw

  • Newbie
  • *
  • Posts: 2
Solved : Noob Help. Installer 404 error
« on: May 10, 2019, 12:26:38 PM »
Hello

Noob here first time setup on a PI with Nginx.  I have followed how to guides.  My issue is that I get a http error 404 not found when I try and run the installer.

Not sure where to go from here.

my config (domain name removed)

 
Code: [Select]
server {
  listen 80;
  server_name mail.your-domain.com;
  return 301 https://mail.your-domain.com/$request_uri;
}

server {
  listen 443 ssl http2;
  server_name mail.your-domain.com;
  root /usr/share/nginx/roundcubemail/;
  index index.php index.html index.htm;

  ssl_certificate /etc/letsencrypt/live/mail.your-domain.com/fullchain.pem;
  ssl_certificate_key /etc/letsencrypt/live/mail.your-domain.com/privkey.pem;

  ssl_session_timeout 1d;
  ssl_session_cache shared:SSL:10m;
  ssl_session_tickets off;
  ssl_protocols TLSv1.1 TLSv1.2;

  ssl_ciphers 'ECDHE-RSA-AES128-GCM-SHA256:ECDHE-ECDSA-AES128-GCM-SHA256:ECDHE-RSA-AES256-GCM-SHA384:ECDHE-ECDSA-AES256-GCM-SHA384:DHE-RSA-AES128-GCM-SHA256:DHE-DSS-AES128-GCM-SHA256:kEDH+AESGCM:ECDHE-RSA-AES128-SHA256:ECDHE-ECDSA-AES128-SHA256:ECDHE-RSA-AES128-SHA:ECDHE-ECDSA-AES128-SHA:ECDHE-RSA-AES256-SHA384:ECDHE-ECDSA-AES256-SHA384:ECDHE-RSA-AES256-SHA:ECDHE-ECDSA-AES256-SHA:DHE-RSA-AES128-SHA256:DHE-RSA-AES128-SHA:DHE-DSS-AES128-SHA256:DHE-RSA-AES256-SHA256:DHE-DSS-AES256-SHA:DHE-RSA-AES256-SHA:!aNULL:!eNULL:!EXPORT:!DES:!RC4:!3DES:!MD5:!PSK';
  ssl_prefer_server_ciphers on;
  error_log /var/log/nginx/roundcube.error;
  access_log /var/log/nginx/roundcube.access;

  location = /50x.html {
    root /usr/share/nginx/html;
  }
  location / {
    try_files $uri $uri/ /index.php;
  }

  error_page 404 /404.html;
  error_page 500 502 503 504 /50x.html;

  location ~ ^/(README|INSTALL|LICENSE|CHANGELOG|UPGRADING)$ {
    deny all;
  }
  location ~ ^/(bin|SQL)/ {
    deny all;
   }

 location ~ \.php$ {
   try_files $uri =404;
   fastcgi_pass unix:/run/php/php7.0-fpm.sock;
   fastcgi_index index.php;
   fastcgi_param SCRIPT_FILENAME $document_root$fastcgi_script_name;
   include fastcgi_params;
 }

 location ~ /.well-known/acme-challenge {
   allow all;
 }
}
Edit

Please help


Solution - I had one to many .conf files lying about
« Last Edit: May 16, 2019, 08:18:26 AM by chewiesw »