Author Topic: ldap Addressbook questions  (Read 3409 times)

Offline LonelyStar

  • Newbie
  • *
  • Posts: 1
ldap Addressbook questions
« on: February 20, 2008, 08:06:11 PM »
Hi,

I am trying to configure my extern ldap addressbook. This is the the part of my config:
Code: [Select]
$rcmail_config['ldap_public']['lonely-star.org'] = array(
  'name'     => 'lonely-star.org',
  'hosts'     => array('127.0.01'),
  'port'     => 389,
  'base_dn'    => 'ou=addressbook,uid=ls,ou=users,dc=lonely-star,dc=org',
  'bind_dn'    => 'uid=ls,ou=users,dc=lonely-star,dc=org',
  'bind_pass'   => '--mypasswd--',
  'ldap_version' => 3,
  'search_fields' => array('mail', 'cn'),
  'name_field'  => 'cn',
  'email_field'  => 'mail',
  'surname_field' => 'sn',
  'firstname_field' => 'givenName',
  'scope'     => 'base ',
  'filter'    => '',
  'fuzzy_search' => true);

The addressbook shows up, but no entries show up.
The file logs/error stays empty (which it does not if I set a wrong option like a wrong password), so I guess there is no error connecting to the ldap server.

Any Ideas?
Thanks!
nathan

Offline mmerlone

  • Jr. Member
  • **
  • Posts: 11
Re: ldap Addressbook questions
« Reply #1 on: March 06, 2008, 08:55:21 AM »
I have the same issue. By increasing the loglevel to 256 on my slapd.conf, I see the queries are made on the ldap server, and they get no error. By running ldapsearch with the sabe base, filter and search attrs I get the entry data from ldap, so it seems the problem is not with the connection, nor the search, but perhaps the exibition of the returned data.

Hope this helps debugging this.
--
Marcio Merlone