Author Topic: Update from 1.1.1 to 1.3.9 - Settings gives blank page  (Read 182 times)

Offline franc

  • Jr. Member
  • **
  • Posts: 19
Update from 1.1.1 to 1.3.9 - Settings gives blank page
« on: July 01, 2019, 09:28:59 AM »
Hallo

I had for long years the 1.1.1 running on my Ubuntu 14.04 with old PHP. Last week I did an upgrade to Ubuntu 16.04 and Roundcube didn't work anymore, after Login I had a blank page.
So I did an update (with bin/installto.sh) as described here: Update your existing Roundcube installation.
After this, Roundcube was working again. But when I click now on the Settings Icon (?_task=settings) I again get a blank page.
In the error log I can read:
Code: [Select]
[01-Jul-2019 15:10:32 Europe/Berlin] PHP Fatal error:  Uncaught Error: Call to undefined function get_input_value() in /var/www/roundcubemail/plugins/settings/settings.php:15
Stack trace:
#0 /var/www/roundcubemail/program/lib/Roundcube/rcube_plugin_api.php(99): settings->init()
#1 /var/www/roundcubemail/program/include/rcmail.php(135): rcube_plugin_api->init(Object(rcmail), 'settings')
#2 /var/www/roundcubemail/program/include/rcmail.php(79): rcmail->startup()
#3 /var/www/roundcubemail/index.php(43): rcmail::get_instance(0, NULL)
#4 {main}
  thrown in /var/www/roundcubemail/plugins/settings/settings.php on line 15
When I look into the settings.php in line 15 there is a kind of packed or obfuscated line starting with "class settings extends rcube_plugin..."
I don't understand this code, too much packed.

What is this? Do I need to uninstall (delete) all Roundcube and reinstall it from scratch?

Thanks for help...

frank

Offline SKaero

  • Administrator
  • Hero Member
  • *****
  • Posts: 5,505
    • http://SKaero.com/
Re: Update from 1.1.1 to 1.3.9 - Settings gives blank page
« Reply #1 on: July 01, 2019, 11:11:43 AM »
You would need to update all the plugins that you are using when you update Roundcube.

Offline franc

  • Jr. Member
  • **
  • Posts: 19
Re: Update from 1.1.1 to 1.3.9 - Settings gives blank page
« Reply #2 on: July 02, 2019, 01:01:02 AM »
I had done already after the roundcube update the composer update (for Plugins) with:

Code: [Select]
php composer.phar update
but this didn't change that fault. Still white page with settings.

Offline JohnDoh

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 2,242
Re: Update from 1.1.1 to 1.3.9 - Settings gives blank page
« Reply #3 on: July 02, 2019, 02:47:04 AM »
are you sure your "settings" plugin is managed via composer, is it listed in your composer.json file?
Roundcube Plugins: Contextmenu, SpamAssassin Prefs, and moreā€¦

Offline franc

  • Jr. Member
  • **
  • Posts: 19
Re: Update from 1.1.1 to 1.3.9 - Settings gives blank page
« Reply #4 on: July 02, 2019, 03:07:07 AM »
No, it is not, but how then update?

Offline franc

  • Jr. Member
  • **
  • Posts: 19
Re: Update from 1.1.1 to 1.3.9 - Settings gives blank page
« Reply #5 on: July 02, 2019, 07:16:05 AM »
This seems to me now some incompatibility from 0.9 to 1.x
I guess when I upgraded to 1.x from 0.9 I did something wrong, because there is this "settings" Plugin, which disappeared in 1.3.9
The plugin is enabled in config.inc.php and not through the composer in the json file.
I cannot update it then, I don't find this "settings" plugin in the repo.

Maybe best would be to install new and just delete the old stuff?

Offline franc

  • Jr. Member
  • **
  • Posts: 19
Re: Update from 1.1.1 to 1.3.9 - Settings gives blank page
« Reply #6 on: July 02, 2019, 07:23:28 AM »
Nope, I just kicked it out in config.inc.php from $config['plugins'] = array(...
where it was listed.
Settings opens now again :)
Dont know what kind of weird "Plugin" this "settings" was.
I installed now the application "composer" which is even easier to handle the updates.
« Last Edit: July 02, 2019, 12:07:00 PM by franc »