Author Topic: IMAPS and SMTPS, login, and folder sync works, but says refused to connect  (Read 587 times)

Offline CanadaGuy

  • Newbie
  • *
  • Posts: 3
I had a few issues getting setup, but now the servers connect find during setup, and I can login and see my IMAP folders, but the right pane shows "example.com refused to connect" when I click on any folders and does not show any messages. In that text, "example.com" is the name of my web server. The web server and firewall are fine since I can use the rest of the RC installation.

I'm running nginx, postfix, dovecot. This occurs both directly accessing the web server, as well as through my reverse proxy.

If you think you can assist, please let me know what else you might need. I run other hosts on this same server and they are working fine. I'm running 1.3.9 and downloaded the "complete" package.

My installation and initial testing was in Chrome, but I tried with Firefox as well. Firefox just shows a blank right panel, while Chrome shows the "refused to connect" message.

*update it seems related to the following issue since the Chrome console reports "Refused to display 'https://example.com/skins/larry/watermark.html' in a frame because it set 'X-Frame-Options' to 'deny'."
https://github.com/roundcube/roundcubemail/issues/6057

« Last Edit: July 02, 2019, 03:03:32 PM by CanadaGuy »

Offline CanadaGuy

  • Newbie
  • *
  • Posts: 3
After digging in the console, and my server config, I noticed that the issue was related to my use of the NGINX snippets I used from here:

https://cipherli.st/

Specifically, I commented out the following:

add_header X-Frame-Options DENY;

Is this issue due to the Roundcube use of iFrames or is this something else? Is there any plan to make Roundcube more friendly to this setting?