Author Topic: Fatal error: ini_set/set_include_path does not work.  (Read 9735 times)

Offline jpkelly

  • Jr. Member
  • **
  • Posts: 11
Fatal error: ini_set/set_include_path does not work.
« on: December 02, 2008, 05:41:43 PM »
I had RC 1.1 working fine on server with PHP 5.2.5. I tried upgrading to RC 2b and i get the error: "Fatal error: ini_set/set_include_path does not work."

Any ideas on how to fix this?

Offline JohnDoh

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 2,275
Fatal error: ini_set/set_include_path does not work.
« Reply #1 on: December 03, 2008, 03:31:15 AM »
take a look at #1484675 (ini_set-problem with RC on PHP 5.2.5) ? RoundCube Webmail ? Trac do you have any values set in your php.ini set with php_admin_value which RC is trying to override and cant?
Roundcube Plugins: Contextmenu, SpamAssassin Prefs, and moreā€¦

Offline jpkelly

  • Jr. Member
  • **
  • Posts: 11
yes thanks!
« Reply #2 on: December 03, 2008, 03:49:20 AM »
that was it.
php_admin_value include_path was set in my apache config.
thanks!

Offline thug

  • Newbie
  • *
  • Posts: 1
Fatal error: ini_set/set_include_path does not work.
« Reply #3 on: September 02, 2010, 05:24:06 AM »
Hello,

I have some problem about roundcube script. I setup RoundCube Webmail scripti to my server. It was working 2 months ago. However, I upgrade php version to 5.2.9 and it doesnt work now.

When i join folder that setup roundcube Mail script;

Fatal error: ini_set/set_include_path does not work.

it is giving error and  if i setup this script again;

Check for required 3rd party libs
This also checks if the include path is set correctly.


Net_SMTP: NOT OK(Failed to load Net/SMTP.php; See Net_SMTP)
Mail_mime: NOT OK(Failed to load Mail/mime.php; See Mail_Mime)
iilConnection: NOT OK(Failed to load lib/imap.inc)

Checking php.ini/.htaccess settings

magic_quotes_gpc: NOT OK(is '0', should be '1')

are giving error. How can i fix this error? Do u have any opinion ?

Offline jrisberg

  • Newbie
  • *
  • Posts: 2
Re: Fatal error: ini_set/set_include_path does not work.
« Reply #4 on: February 07, 2013, 01:14:55 PM »
My setup:
Plesk 9.5
PHP 5.3.2.1
Fedora Core 8 (I know)
Roundcube .85 installed in place of Horde

After a PHP upgrade broke Roundcube I went in circles with this error until I realized it meant that it couldn't define the include_path because it was already set elsewhere.

The solution in my case was to comment out the four instances of "php_admin_value include_path" in the /etc/httpd/conf.d/zzz_horde_vhost.conf file and restart apache. This cleared up the error immediately and Roundcube is working perfectly again.

It was frustrating to find many forum posts over the years asking for help with this error and no adequate responses other than the occasional "I fixed it -- nevermind" or "it's not a bug in Roundcube" non-response. Hope this is more helpful.

Joel Risberg
« Last Edit: February 13, 2013, 06:27:23 PM by jrisberg »

Offline EthraZa

  • Newbie
  • *
  • Posts: 4
Re: Fatal error: ini_set/set_include_path does not work.
« Reply #5 on: August 20, 2019, 09:00:44 AM »
My setup:
Plesk 9.5
PHP 5.3.2.1
Fedora Core 8 (I know)
Roundcube .85 installed in place of Horde

After a PHP upgrade broke Roundcube I went in circles with this error until I realized it meant that it couldn't define the include_path because it was already set elsewhere.

The solution in my case was to comment out the four instances of "php_admin_value include_path" in the /etc/httpd/conf.d/zzz_horde_vhost.conf file and restart apache. This cleared up the error immediately and Roundcube is working perfectly again.

It was frustrating to find many forum posts over the years asking for help with this error and no adequate responses other than the occasional "I fixed it -- nevermind" or "it's not a bug in Roundcube" non-response. Hope this is more helpful.

Joel Risberg

RC 1.4RC1 + PHP 7.1 here and I've just found out you are still right. Thank you sir.