Author Topic: Should I wait for 1.4.0 ?  (Read 2459 times)

Offline oukourj

  • Newbie
  • *
  • Posts: 8
Should I wait for 1.4.0 ?
« on: October 28, 2019, 06:34:03 AM »
Hi, so I'm just mounting a new e-mail server to replace our antique server with Horde version "prehistory".

I'm at the point of setting up the webmail, but the question is will it be easy to update from RC2 to final or should I wait for final release ?
It's my first "from scratch" install of a webmail, but not my first work with web servers.

A side question would be, is there an ETA for final ? If it's a few days I'll definitely be waiting.
« Last Edit: October 28, 2019, 09:03:12 AM by oukourj »

Online SKaero

  • Administrator
  • Hero Member
  • *****
  • Posts: 5,611
    • http://SKaero.com/
Re: Should I wait for 1.4.0 ?
« Reply #1 on: October 28, 2019, 11:59:14 AM »
I don't think you have to wait for the final 1.4.0 release upgrades are simple. The final release doesn't have a date planed at this point but should happen before the end of November.

Offline oukourj

  • Newbie
  • *
  • Posts: 8
Re: Should I wait for 1.4.0 ?
« Reply #2 on: October 29, 2019, 06:48:12 AM »
Okay thank you.

(EDIT: I installed successfully using an external tutorial.

Just some feedback : the /installer is a very convenient way to finalize the configuration, but it could use an update regarding the tls:// rule which is absent. It may be self-evident for seasoned admins, but for me, the simple fact that tls:// wasn't mentionned made me hesitate. Finally found on a forum that I indeed had to specify it, my default conclusion being that the precision was needed for older SSL only

Also, but I'm not sure about this one because it may be too specific for my case, but the TLS auth wouldn't work because my certificate expected a connection to the host specified in it's CN, and not localhost. It may be worth it having this little hint below the default 'localhost' entries, as I've seen some forum posts about this since PHP5.6 who doesn't accept hostname/cert missmatches anymore).
« Last Edit: October 29, 2019, 09:46:43 AM by oukourj »

Online SKaero

  • Administrator
  • Hero Member
  • *****
  • Posts: 5,611
    • http://SKaero.com/
Re: Should I wait for 1.4.0 ?
« Reply #3 on: October 29, 2019, 09:43:56 AM »
It would be a good idea to use the instructions in the INSTALL file for the release https://github.com/roundcube/roundcubemail/blob/1.4-rc2/INSTALL some of the requirements have changed.