Author Topic: SOLVED:DB Error: SQLSTATE[HY000][2002] No such file or directory in rcube_db.php  (Read 668 times)

Offline andreas_x

  • Newbie
  • *
  • Posts: 2
Greetings. I'm using Roundcube 1.4.3 on OpenBSD. Everything is working fine, expect the password plugin. Whenever I try to change my password, it gives the error: "Could not save new password".

When I check the Roundcube's log file, it has:

[02-Mar-2020 13:13:51 +0000]: <bfoktlpd> DB Error: SQLSTATE[HY000] [2002] No such file or directory in /htdocs/wmail/program/lib/Roundcube/rcube_db.php on line 175 (POST /wmail/?_task=settings&_action=plugin.password-save)

The mentioned line (rcube_db.php) is:
'line' => __LINE__, 'file' => __FILE__,

and actually,
/htdocs/wmail/program/lib/Roundcube/rcube_db.php in Roundcube's errors.log, is located at
/var/www/htdocs/wmail/program/lib/Roundcube/rcube_db.php

Nginx is chrooted into /var/www by the default on OpenBSD. Could that be the problem? Any idea?

P.S: I have every required and optional/recommended php extensions enabled, nothing is missing on the system for Roundcube to run intact.

Many thanks for your great effort, for such a great Webmail! Truly appreciated!
Regards.
« Last Edit: March 02, 2020, 08:49:29 AM by andreas_x »

Offline andreas_x

  • Newbie
  • *
  • Posts: 2
Fixed!
inside config.inc.php file of password plugin (folder), I replaced the line:

$config['password_dovecotpw'] = '/usr/local/sbin/dovecotpw'; // for dovecot-1.x

with:

$config['password_dovecotpw'] = '/usr/local/bin/doveadm pw';

And it worked! So it seems "no such file or directory" was referring the doveadm binary path.