Author Topic: Delete and Next Functionality Not Working on 1.4.3  (Read 587 times)

Offline slashmail

  • Newbie
  • *
  • Posts: 4
Delete and Next Functionality Not Working on 1.4.3
« on: April 29, 2020, 07:55:22 AM »
I have a user that this functionality is not working (shift highlight multiple emails in inbox, delete and then the focus should go to the next email in the list - it instead goes to a new small little bar to the left of the email instead).  This worked prior to the 1.4.3 upgrade.  A few notes:

1.  Larry Theme
2.  Display next list entry after delete/move is checked in Settings
3.  Layout is List/No Preview

I'm able to login to his account and it works on my computer in Firefox and Chrome.  Does not work on his computers (multiple) in Firefox.  I've attached a screenshot of where the focus goes in his screen.

Any thoughts or ideas?

Offline JohnDoh

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 2,438
Re: Delete and Next Functionality Not Working on 1.4.3
« Reply #1 on: April 30, 2020, 12:28:24 PM »
This is an intentional change in 1.4 now the display_next setting only applies when a message/contact is being viewed (e.g in the preview pane) see https://github.com/roundcube/roundcubemail/issues/6795
Roundcube Plugins: Contextmenu, SpamAssassin Prefs, and more…

Offline slashmail

  • Newbie
  • *
  • Posts: 4
Re: Delete and Next Functionality Not Working on 1.4.3
« Reply #2 on: April 30, 2020, 12:37:51 PM »
John - is that just the Elastic skin?  This user is using the Larry skin.


Offline slashmail

  • Newbie
  • *
  • Posts: 4
Re: Delete and Next Functionality Not Working on 1.4.3
« Reply #3 on: April 30, 2020, 06:00:14 PM »
Update:

I forced the change to the web UI layout in the settings for the user and it took affect and now works.  Unfortunately, they like the preview pane and this no longer works.  Any chance of getting the preview pane with Larry skin and this functionality to work again?  It worked in the previous version.

Thanks!


Offline JohnDoh

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 2,438
Re: Delete and Next Functionality Not Working on 1.4.3
« Reply #4 on: May 01, 2020, 02:36:11 AM »
What do you mean? I don't think the behavior has changed when the preview pane is enabled.
Roundcube Plugins: Contextmenu, SpamAssassin Prefs, and more…

Offline slashmail

  • Newbie
  • *
  • Posts: 4
Re: Delete and Next Functionality Not Working on 1.4.3
« Reply #5 on: May 01, 2020, 07:33:19 AM »
John,

The 'delete and next' functionality (shift - delete multiple emails with focus going to the next email in the list) does not work in the Larry theme unless the UI mode has preview off -- needs to be "Layout is List/No Preview". 

If this still works for others, is there something in my configuration that needs to be explored?


Offline JohnDoh

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 2,438
Re: Delete and Next Functionality Not Working on 1.4.3
« Reply #6 on: May 01, 2020, 11:47:11 AM »
I think I see what you mean the behavior was changed to make it so that if there was not a message shown in the preview pane when you hit delete then there will also not be on in the preview pane afterwards.

So when you select multiple messages then the preview pane in blank and so after you hit delete then nothing is selected so the preview pane remains empty.

I think its different in list mode because then there is no preview pane and so highlighting a message in the list has no other effect (like opening that message in the preview pane) but I don't know.
Roundcube Plugins: Contextmenu, SpamAssassin Prefs, and more…