Author Topic: Roundcube won't respond under httpS [SOLVED]  (Read 115 times)

Offline tbuckler

  • Newbie
  • *
  • Posts: 1
Roundcube won't respond under httpS [SOLVED]
« on: September 08, 2020, 07:57:28 PM »
Hello,

I'm serving up Roundcube 1.4.8 using & it works fine as HTTP (no ssl).

When using HTTPS, I get the login screen, but all responses (with valid or bogus credentials) fail with ..."the server unexpectedly dropped the connection"... or "This page isn’t working nnn.tld didn’t send any data.
ERR_EMPTY_RESPONSE "

Debugging in Roundcube produces very little in session.log (a session destroy entry only), nor any errors in Apache's error_log.

I have another site using SSL successfully in the same instance of Apache. As well, https://www.ssllabs.com/ssltest/ checks out the website as OK (other than DNS CAA).

Where can I go from here to figure this out?
Thanks,
Tom


====================

Turns out that something is/was wrong with PHP. So even though a Wordpress site and another php site world fine, neither RoundCube nor my mail server's native web-mail would work until I reverted back to a previous version of PHP.
« Last Edit: September 09, 2020, 12:12:07 AM by tbuckler »