Author Topic: login failed in roundcube only  (Read 473 times)

Offline r2zvi

  • Newbie
  • *
  • Posts: 6
login failed in roundcube only
« on: February 03, 2021, 08:31:55 AM »
environment: postfix + dovecot + postfixadmin + mysql + roundcube
two domains set up, i can login every account in both domains with thunderbird

config.inc.php:
Code: [Select]
// system error reporting, sum of: 1 = log; 4 = show
$config['debug_level'] = 4;
// Log SQL queries
$config['sql_debug'] = true;
// Log IMAP conversation
$config['imap_debug'] = true;
// Log LDAP conversation
$config['ldap_debug'] = true;
// Log SMTP conversation
$config['smtp_debug'] = true;
$config['db_dsnw'] = 'mysql://roundcube:PASS@localhost/roundcubemail';
$config['default_host'] = 'localhost';
$config['default_port'] = 143;
$config['smtp_server'] = 'localhost';
$config['smtp_port'] = 25;
$config['smtp_user'] = '%u';
$config['smtp_pass'] = '%p';
$config['plugins'] = array(
    'archive',
    'zipdownload',
);
maillog:
Code: [Select]
Feb  3 21:22:43 mx dovecot: imap-login: Disconnected (auth failed, 1 attempts in 2 secs): user=<user@domain.ltd>, method=CRAM-MD5, rip=127.0.0.1, lip=127.0.0.1, secured, session=<bB5Je266ioN/AAAB>
where should i start to figure out the problem? Thanks

Offline alec

  • Hero Member
  • *****
  • Posts: 1,227
Re: login failed in roundcube only
« Reply #1 on: February 03, 2021, 10:20:20 AM »
default_host='tls://localhost'

Offline r2zvi

  • Newbie
  • *
  • Posts: 6
Re: login failed in roundcube only
« Reply #2 on: February 03, 2021, 09:32:25 PM »
i tried that, no luck,  "Connection to storage server failed"
and in maillog, there is no user name presented, the same applies to "ssl://localhost"
Code: [Select]
Feb  4 02:28:23 mx dovecot: imap-login: Disconnected (no auth attempts in 0 secs): user=<>, rip=127.0.0.1, lip=127.0.0.1, TLS, session=<A3QrdXm6lIN/AAAB>

Offline alec

  • Hero Member
  • *****
  • Posts: 1,227
Re: login failed in roundcube only
« Reply #3 on: February 04, 2021, 02:20:03 AM »
Look into Roundcube error log, and/or enable imap_debug there. It may give you some hints.

Offline r2zvi

  • Newbie
  • *
  • Posts: 6
Re: login failed in roundcube only
« Reply #4 on: February 04, 2021, 03:06:35 AM »
well, if you look closely, i've already turned on all the log options in config.inc.php, but no any other logs found except the ones posted here.
Thanks for your help anyway

Offline JohnDoh

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 2,551
Re: login failed in roundcube only
« Reply #5 on: February 04, 2021, 03:57:46 PM »
Did you disable the SSL certificate verification? see imap_conn_options
Roundcube Plugins: Contextmenu, SpamAssassin Prefs, and moreā€¦

Offline r2zvi

  • Newbie
  • *
  • Posts: 6
Re: login failed in roundcube only
« Reply #6 on: February 04, 2021, 11:55:43 PM »
i added the following code in config.inc.php, but still got the same error and logs
Code: [Select]
$config['imap_conn_options'] = array(
  'ssl' => array(
    'verify_peer'  => false,
    'verify_peer_name' => false,
  ),
);

Offline r2zvi

  • Newbie
  • *
  • Posts: 6
Re: login failed in roundcube only
« Reply #7 on: February 05, 2021, 12:12:07 AM »
logs in maillog look just like login failed with wrong password, but with the same password i can login with thunderbird and python imaplib in remote client
there is no extra info/logs to analyze so i have no clue where to start debugging

i have another machine running dovecot + postfix + sqlite + roundcube(1.4.9) with single domain which works well, copy and modify config.inc.php didn't make the problem disappear

Offline r2zvi

  • Newbie
  • *
  • Posts: 6
Re: login failed in roundcube only
« Reply #8 on: February 05, 2021, 01:18:57 AM »
i actually replaced it with rainloop and it works well and smoothly  :-\