Author Topic: not upgrade  (Read 526 times)

Offline pipounix

  • Newbie
  • *
  • Posts: 1
not upgrade
« on: February 23, 2021, 06:26:53 PM »
root@unix-it:/# apt upgrade
Leyendo lista de paquetes... Hecho
Creando árbol de dependencias
Leyendo la información de estado... Hecho
Calculando la actualización... Hecho
Los paquetes indicados a continuación se instalaron de forma automática y ya no son necesarios.
  linux-image-4.9.0-11-amd64 linux-image-4.9.0-12-amd64
Utilice «apt autoremove» para eliminarlos.
0 actualizados, 0 nuevos se instalarán, 0 para eliminar y 0 no actualizados.
3 no instalados del todo o eliminados.
Se utilizarán 0 B de espacio de disco adicional después de esta operación.
¿Desea continuar? [S/n] s
Configurando roundcube-core (1.2.3+dfsg.1-4+deb9u8) ...
Determining localhost credentials from /etc/mysql/debian.cnf: succeeded.
dbconfig-common: writing config to /etc/dbconfig-common/roundcube.conf
dbconfig-common: flushing administrative password
PHP Warning:  Undefined variable $rcmail_config in /usr/share/roundcube/program/lib/Roundcube/rcube_config.php on line 323
PHP Warning:  Undefined variable $rcmail_config in /usr/share/roundcube/program/lib/Roundcube/rcube_config.php on line 323
PHP Warning:  Undefined array key 2 in /usr/share/roundcube/program/lib/Roundcube/rcube_charset.php on line 118
PHP Warning:  Undefined array key "UTF-8" in /usr/share/roundcube/program/lib/Roundcube/rcube_charset.php on line 232
PHP Warning:  Undefined array key "UTF7-IMAP" in /usr/share/roundcube/program/lib/Roundcube/rcube_charset.php on line 233
PHP Warning:  Undefined array key "UTF-8" in /usr/share/roundcube/program/lib/Roundcube/rcube_charset.php on line 232
PHP Warning:  Undefined array key "UTF7-IMAP" in /usr/share/roundcube/program/lib/Roundcube/rcube_charset.php on line 233
PHP Warning:  Undefined array key "UTF-8" in /usr/share/roundcube/program/lib/Roundcube/rcube_charset.php on line 232
PHP Warning:  Undefined array key "UTF7-IMAP" in /usr/share/roundcube/program/lib/Roundcube/rcube_charset.php on line 233
PHP Warning:  Undefined array key "UTF-8" in /usr/share/roundcube/program/lib/Roundcube/rcube_charset.php on line 232
PHP Warning:  Undefined array key "UTF7-IMAP" in /usr/share/roundcube/program/lib/Roundcube/rcube_charset.php on line 233
PHP Warning:  Undefined variable $proto in /usr/share/roundcube/program/lib/Roundcube/rcube_db.php on line 1201
PHP Warning:  Undefined variable $proto in /usr/share/roundcube/program/lib/Roundcube/rcube_db.php on line 1201
PHP Warning:  Undefined array key "config_get" in /usr/share/roundcube/program/lib/Roundcube/rcube_plugin_api.php on line 438
PHP Fatal error:  Uncaught TypeError: count(): Argument #1 ($var) must be of type Countable|array, null given in /usr/share/roundcube/program/lib/Roundcube/rcube_plugin_api.php:438
Stack trace:
#0 /usr/share/roundcube/program/lib/Roundcube/rcube_config.php(404): rcube_plugin_api->exec_hook()
#1 /usr/share/roundcube/program/include/rcmail.php(99): rcube_config->get()
#2 /usr/share/roundcube/program/include/rcmail.php(79): rcmail->startup()
#3 /usr/share/roundcube/program/include/clisetup.php(31): rcmail::get_instance()
#4 /usr/share/roundcube/bin/update.sh(31): require_once('...')
#5 {main}
  thrown in /usr/share/roundcube/program/lib/Roundcube/rcube_plugin_api.php on line 438
PHP Warning:  Undefined array key "REMOTE_ADDR" in /usr/share/roundcube/program/lib/Roundcube/rcube.php on line 999
PHP Warning:  Undefined array key "config_get" in /usr/share/roundcube/program/lib/Roundcube/rcube_plugin_api.php on line 438
PHP Fatal error:  Uncaught TypeError: count(): Argument #1 ($var) must be of type Countable|array, null given in /usr/share/roundcube/program/lib/Roundcube/rcube_plugin_api.php:438
Stack trace:
#0 /usr/share/roundcube/program/lib/Roundcube/rcube_config.php(404): rcube_plugin_api->exec_hook()
#1 /usr/share/roundcube/program/lib/Roundcube/rcube.php(1017): rcube_config->get()
#2 /usr/share/roundcube/program/include/rcmail.php(871): rcube->shutdown()
#3 [internal function]: rcmail->shutdown()
#4 {main}
  thrown in /usr/share/roundcube/program/lib/Roundcube/rcube_plugin_api.php on line 438
dpkg: error al procesar el paquete roundcube-core (--configure):
 el subproceso instalado el script post-installation devolvió el código de salida de error 255
dpkg: problemas de dependencias impiden la configuración de roundcube-plugins:
 roundcube-plugins depende de roundcube-core (= 1.2.3+dfsg.1-4+deb9u8); sin embargo:
 El paquete `roundcube-core' no está configurado todavía.

dpkg: error al procesar el paquete roundcube-plugins (--configure):
 problemas de dependencias - se deja sin configurar
dpkg: problemas de dependencias impiden la configuración de roundcube:
 roundcube depende de roundcube-core (= 1.2.3+dfsg.1-4+deb9u8); sin embargo:
 El paquete `roundcube-core' no está configurado todavía.

dpkg: error al procesar el paquete roundcube (--configure):
 problemas de dependencias - se deja sin configurar
Se encontraron errores al procesar:
 roundcube-core
 roundcube-plugins
 roundcube
E: Sub-process /usr/bin/dpkg returned an error code (1)

Offline alec

  • Hero Member
  • *****
  • Posts: 1,239
Re: not upgrade
« Reply #1 on: February 24, 2021, 01:55:12 AM »
Roundcube 1.2 was released in 2016, PHP8 was released in 2020. Guess what?